Announcement

Collapse
No announcement yet.

Possible hack? Getting a parse error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Possible hack? Getting a parse error

    First of all let me say that I have a customized forum, with no plugins. I have the latest 3.7.3 patch level 1 installed and its been running good for a month since I upgraded. Lately I'm getting an error on the main page, and also when I click "user cp". It seems to be intermittent.

    It's like this:
    Parse error: syntax error, unexpected $end in/home/consa3/public_html/forums/profile.php on line 2642
    I've done some research and it seems that a change in the php.ini file associated with short_open_tag in PHP.INI may be the problem. I have yet to try and find or change this file.

    I've also had a web designer looking over my pages lately for some planned changes, but I didn't authorize any. I'm suspicious of hackers because its been running good without a problem since the upgrade. Any ideas?

  • #2
    The profile.php file was partly missing and it ended at line 2642!

    Why would my forum work so well for so long with this file not completely there? I have my doubts. I just re-uploaded it and all is well. Very strange.

    Comment


    • #3
      Could be an incomplete upload or someone was playing with the file and saved it inadvertantly. A cause for concern if you haven't given anyone else FTP access.

      Your forum would work, apart from any pages that reference profile.php. You possibly didn't notice the error earlier because you don't access any profile.php pages often. Either that, or it's a recent change.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X