Announcement

Collapse
No announcement yet.

Google Chrome error for the useragent field

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    Originally posted by Andy View Post
    It would be good if the vBulletin team could increase the field length to 150.
    As the entire session table is stored in memory, increasing this isn't a sound choice. Large forums with 1000 or concurrent users means this is another 50K or more RAM memory they need.

    vBulletin does not need to know the entire contents of the user agent field to operate and it should be automatically truncated to 100 characters.

    Leave a comment:


  • alessio
    replied
    in effect it do not happen on a gnu-linux based machine with all latest versions for services installations, while it come out for sure on a windows machine with Php 4.4.4 and MySQL 5.0. Maybe it can help.

    Leave a comment:


  • Andy
    replied
    I don't get any errors, but I have noticed that the field is too short and the useragent information is truncated.

    It would be good if the vBulletin team could increase the field length to 150.

    Leave a comment:


  • alessio
    started a topic Google Chrome error for the useragent field

    Google Chrome error for the useragent field

    An error for vBulletin using Google Chrome have come out.
    It can be solved by giving to the vBulletin session an increased value for the useragent column (the vBulletin default install set a value of 100 chars for the useragent column in the database while seem with Chrome can happen that isn't a sufficient value (and an ERROR num. 2 is returned also by the same browser)) .
    This is the error log as the vBulletin class have return:
    Code:
    Database error in vBulletin 3.7.3:
    Invalid SQL:
    UPDATE vbsession
    SET lastactivity = 1225462039, inforum = 0, inthread = 0, incalendar = 0, badlocation = 0, useragent = 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.13 (KHTML, like Gecko) Chrome/0.2.149.30 Safari/525.13'
    WHERE sessionhash = '7a193e0daa99351810fdd2dbc1241d9d';
    Increasing the char value for the useragent field (for example from 100 to 150) solve this issue.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X