Announcement

Collapse
No announcement yet.

Problem with save style

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Brew
    replied
    I can't find any settings for suhosin in my php.ini file.

    But I do have this:

    extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20060613"
    extension="suhosin.so"

    Is there a suhosin.ini file I need to make the changes to? Or do I just add the following below what is in the php.ini file?

    [suhosin]
    suhosin.request.max_vars = 2048
    suhosin.post.max_vars = 2048
    suhosin.cookie.encrypt = Off

    Also, my php.ini file is set to read only. How do I get around that? I've tried to save the file with :!wq but that doesn't work (using vi).

    I have also added the lines in the .htaccess file:

    php_value suhosin.request.max_vars 2048
    php_value suhosin.post.max_vars 2048
    php_value suhosin.cookie.encrypt Off

    But I still get the same problem the original poster to this thread gets.

    Thanks for your help

    Oh yea....

    I have php ver 5.2.6

    Leave a comment:


  • Floris
    replied
    Depending on the page with the error you might need to change the following using a suggested value of 1024 or 2048 for NewValue in .htaccess:
    Code:
    php_value suhosin.request.max_vars NewValue
    php_value suhosin.post.max_vars NewValue

    And otherwise try :
    php_flag suhosin.cookie.encrypt Off


    If this all doesn't work, it has to be done via php.ini

    Leave a comment:


  • Danial_Faster
    started a topic Problem with save style

    Problem with save style

    Hello,
    I when save style ,
    Disply below error,
    Code:
    Required variables have gone missing and execution can not continue. Please try  again.
    
    This error can sometimes occur as a result of Suhosin / Hardened  PHP being installed on your server. If you know that you have Suhosin running  and you have access to the PHP configuration, try increasing the value of the  following variables:  [LIST][*]php_value suhosin.post.max_vars[*]php_value suhosin.request.max_vars[/LIST]
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X