Announcement

Collapse
No announcement yet.

I LOST one forum! Please help me!!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I LOST one forum! Please help me!!!

    I lost one forum from main page.
    Login to admin panel. Script write "Table 'forum' have error. Blablabla". I check table 'forum' from control panel:

    Code:
    forum Check Warning: Table is marked as crashed 
    forum Check Warning: 4 clients are using or haven't closed the table properly 
    forum Check Warning: Found 820 deleted space in delete link chain. Should be 912 
    forum Check Error: Found 15 deleted rows in delete link chain. Should be 17 
    forum Check Error: record delete-link-chain corrupted 
    forum Check Error: Corrupt
    Now I dont have this forum
    Code:
    Invalid Forum specified. If you followed a valid link, please notify the administrator
    All thread from this forum write: Your dont have access.
    This forum had 1,972 threads and 28,687 posts...

    Pleeeease help me
    Last edited by Dimoks; Thu 23rd Oct '08, 6:16am.

  • #2
    Have you tried running Repair/Optimize on the table? admin cp > maintenance > repair/optimize tables > select the forum table > hit repair/optimize. You may have to do this a couple of times.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      I have old backup. Realy table 'forum' from backup add to new mysql base?

      Comment


      • #4
        Did you try what I suggested? Tables crash all the time and usually if you repair them, they are fine.

        You cannot add a single forum from an old backup.

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help

        Comment


        • #5
          Originally posted by Lynne View Post
          Have you tried running Repair/Optimize on the table? admin cp > maintenance > repair/optimize tables > select the forum table > hit repair/optimize. You may have to do this a couple of times.
          repair some times... script write "table ok"
          Last edited by Dimoks; Thu 23rd Oct '08, 7:11am.

          Comment


          • #6
            Add old table 'forum' in new mysql base... All ok...... But script write error if add new forum.

            Code:
            Database error in vBulletin 3.7.3:
            Invalid SQL:
            INSERT INTO forum
             (title_clean, title, description_clean, description, link, displayorder, parentid, daysprune, defaultsortfield, defaultsortorder, showprivate, newpostemail, newthreademail, options, styleid, imageprefix, password, excludable)
            VALUES
             ('Экономика', 'Экономика', 'Экономика, финансы, кредиты обсуждают тут', 'Экономика, финансы, кредиты обсуждают тут', '', 3, 56, -1, 'lastpost', 'desc', 0, '', '', 97991, 0, '', '', 0);
            MySQL Error   : Unknown column 'excludable' in 'field list'
            Error Number  : 1054
            Request Date  : Thursday, October 23rd 2008 @ 06:41:36 PM
            Error Date    : Thursday, October 23rd 2008 @ 06:41:36 PM
            Script        : http://www.kharkovforum.com/******/forum.php?do=update
            Referrer      : http://www.kharkovforum.com/******/forum.php?do=add
            IP Address    : *********
            Username      : Dimoks
            Classname     : vB_Database
            MySQL Version : 5.1.28-rc-log

            Comment


            • #7
              There is no column 'excludable' in a default vb table 'forum', so that error is because of an add-on. Try disabling the add-ons and try again.

              Please don't PM or VM me for support - I only help out in the threads.
              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
              Want help modifying your vbulletin forum? Head on over to vbulletin.org
              If I post CSS and you don't know where it goes, throw it into the additional.css template.

              W3Schools <- awesome site for html/css help

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X