Announcement

Collapse
No announcement yet.

Mucho issues this morning

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mucho issues this morning

    Sometime in the last 24 hours, my vB 7.1 (I think that is the version) started having issues. I was out-of-town so only have the following info to provide.

    1. Users were getting error codes after posting.
    2. The thread post count was not updating.
    3. Some users said their browser froze when attempting to log onto the forum.
    4. When I tried to log on and delete some posts, I got a parse error though the post actually did delete.
    5. I could not get into the admin. So put a backup of admin.php on and immediately got the following:

    Fatal error: Cannot use string offset as an array in /home/*****/public_html/goForum/includes/functions.php on line 1024

    Putting a backup functions.php file in its place changed the line but did nothing else. Now the forum is completely down.
    6. Some report a window which asks about downloading a file called getfile.php.

    I ran a repair on the database but had no luck. Any suggestions as to where to begin troubleshooting? Thanks.

  • #2
    If the errors are increasing, and you get weird files like getfile.php - then perhaps you're getting hacked.

    Comment


    • #3
      I see. Not good.

      What would be the best approach to begin correcting the matter? Or is it easier to reinstall a backup from before the troubles began (even though I lose a lot of posts)?

      Comment


      • #4
        In regards to the hosting: ask the host to look into it and change all your mysql/ftp/email/etc passwords.

        How To Make My Forums More Secure

        Ask your host to reset to a backup from a day before, and check if you are in fact hacked.

        Comment


        • #5
          Many thanks for your help. The host is investigating now.

          Comment


          • #6
            This was indeed a hack. It's taken a number of days to get the files back in order. However, this error code still remains:

            Fatal error: Cannot use string offset as an array in /home/******/public_html/goForum/includes/functions.php on line 1024

            According to the host, the next step is to do a clean install of the server. I wanted to check here to see if anyone may have experienced this issue and have any suggestions.

            Comment


            • #7
              To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

              Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions


              [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

              Next, disable all plugins.

              Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

              define('DISABLE_HOOKS', true);

              Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Thanks for the reply, Steve. I'll begin the process and see where it gets me. Thanks.

                Comment


                • #9
                  An update made everything wonderful again except I can't upload now. I get this error:

                  PHP Error: The function exec() has been disabed

                  Comment


                  • #10
                    Your host has disabled the exec() function in PHP. You need to ask them to enable this.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      It took a clean install of the server OS in order to rid us of the virus.

                      In the process, I can now no longer upload photos to the site from my computer. I get an error like "invalid file, or invalid URL".

                      Any suggestions? Thanks.

                      Comment


                      • #12
                        Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

                        Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Originally posted by Steve Machol View Post
                          Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

                          Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
                          Enabled phpinfo and got this:
                          No Image specified. If you followed a valid link, please notify the administrator

                          When you provide URL to the forums, are you talking about the Safe Mode Temporary Directory? I don't have Safe Mode on.

                          Thanks.

                          Comment


                          • #14
                            exec() isnt listed as disabled in your phpinfo, are you still having the same issue?

                            Comment


                            • #15
                              The only thing I see that could cause this is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

                              You will also need to restart Apache after making this change.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X