Announcement

Collapse
No announcement yet.

Database issues on upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database issues on upgrade

    I have just updated a very old forum to the newest software and had some problems with the phrase table. Someone tried fixing it for me because it was broken and in the end, deleted the phrase table!

    So now i cannot do the upgrade because the table 'phrase' does not exist, so everything is now not working.

    How can i fix this? Is there anyway to re-install the phrase part of the table?

    Thanks for any help, hope this makes sense.

  • #2
    Run this query to recreate that table:

    CREATE TABLE phrase (
    phraseid INT UNSIGNED NOT NULL AUTO_INCREMENT,
    languageid SMALLINT NOT NULL DEFAULT '0',
    varname VARCHAR(250) BINARY NOT NULL DEFAULT '',
    fieldname VARCHAR(20) NOT NULL DEFAULT '',
    text MEDIUMTEXT,
    product VARCHAR(25) NOT NULL DEFAULT '',
    username VARCHAR(100) NOT NULL DEFAULT '',
    dateline INT UNSIGNED NOT NULL DEFAULT '0',
    version VARCHAR(30) NOT NULL DEFAULT '',
    PRIMARY KEY (phraseid),
    UNIQUE KEY name_lang_type (varname, languageid, fieldname),
    KEY languageid (languageid, fieldname)
    );


    Then reupload the original vbulletin-language.xml file to the install directory. Then upload the tools.php script in the 'do_not_upload' folder of the vB zip file to your Admin CP directory and run it from your browser. Then reimport the vbulletin-language.xml file. Immediately remove tools.php when you are done.

    Then run this in the Admin CP:

    Admin CP -> Languages & Phrases -> Language Manager -> [Rebuild All Languages]
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X