Announcement

Collapse
No announcement yet.

Hmmmmmm SELECT query?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hmmmmmm SELECT query?

    Just saw these in my log

    Invalid SQL:

    (SELECT permissions, permissions2, FIND_IN_SET(forumid, '237,195,116,-1') AS pos, forumid
    FROM moderator
    WHERE userid = 66586 AND forumid IN (237,195,116,-1)
    ORDER BY pos ASC
    LIMIT 1)
    UNION
    (SELECT permissions, permissions2, 0, forumid
    FROM moderator
    WHERE userid = 66586 AND forumid = -1
    );
    There's a few of them, all from the same user. Any idea? It just bothers me that they're doing something that is hitting the moderator table, is that normal? (This is not a mod or admin)
    Webkinz

  • #2
    We need the full vbulletin mysql error. So we know what script, which referrer, what versions, etc. This error you posted only says the query is invalid. nothing else.

    Comment


    • #3
      No problem:
      Database error in vBulletin 3.7.1:

      Invalid SQL:

      (SELECT permissions, permissions2, FIND_IN_SET(forumid, '237,195,116,-1') AS pos, forumid
      FROM moderator
      WHERE userid = 66586 AND forumid IN (237,195,116,-1)
      ORDER BY pos ASC
      LIMIT 1)
      UNION
      (SELECT permissions, permissions2, 0, forumid
      FROM moderator
      WHERE userid = 66586 AND forumid = -1
      );

      MySQL Error : MySQL server has gone away
      Error Number : 2006
      Request Date : Friday, October 3rd 2008 @ 05:33:18 PM
      Error Date : Friday, October 3rd 2008 @ 05:33:38 PM
      Script : http://www.webkinzinsider.com/forum/...stthread&f=237
      Referrer : http:/www.xxxxx.com/forum/newthread.php?do=newthread&f=237
      IP Address : 75.5.75.157
      Username : shadowsown88
      Classname : vB_Database
      MySQL Version :
      Webkinz

      Comment


      • #4
        MySQL server has gone away

        This is not clear enough. I do not know why the mysql server decided to go away .. the first post error indicates a wrongful query, but the query is fine, otherwise the 'gone away' error msg wouldn't be that.


        perhaps turn off the hook system, upgrade to 3.7.3 pl1 in case this is a bug , so it should be fixed hopefully. And see if it still happens, if not, turn on the hook system, and see if it comes back, if so, then it's one of the plugins buggin in.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X