Announcement

Collapse
No announcement yet.

Getting Invalid SQL Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting Invalid SQL Error

    Any idea what this error is being caused by?

    Database error in vBulletin 3.7.3:

    Invalid SQL:

    SELECT text, languageid, special
    FROM phrase AS phrase
    LEFT JOIN phrasetype USING (fieldname)
    WHERE phrase.fieldname = 'error'
    AND varname = 'php_error_unspecified_exec' AND languageid IN (-1, 0, 0);

    MySQL Error :
    Error Number :
    Request Date : Friday, October 3rd 2008 @ 11:17:15 AM
    Error Date : Friday, October 3rd 2008 @ 11:17:16 AM
    Script : http://zpay.com/vbulletin/image.php?hash=test&i=im
    Referrer :
    IP Address : 66.249.66.8
    Username :
    Classname : vB_Database
    MySQL Version :

    Thanks,

    Paul

  • #2
    Note: This may be a problem with ImageMagick.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Before I can confirm this might be a potential bug, could you please provide me with additional information?

      Did you recently upgrade from an older version?
      Did you only just try to change this setting?
      Do you run 3.7.3 or 3.7.3 PL1?
      Can you link to your phpinfo.php file? (content: <?=phpinfo();?>)
      What version of OS/webserver/PHP/MySQL do you have?
      Is imagemagick properly installed and working on your server?
      What kind of hosting account do you have?
      Do you have any customizations done to the files?
      Do you have any products or plugins installed?
      Does this error also occur when you add define('DISABLE_HOOKS', true); below <?php in the config.php file?
      When you run admincp>maintenance>diagnostics>file suspect version > do you get any results, like mismatching files or files missing?

      Comment


      • #4
        OK, I had installed ImageMagick yesterday on the server but was not able to get it working. So it was uninstalled and I "blanked" the path I had entered in the vBulletin settings and signed up for and set vBulletin to use reCAPTCHA.

        So where should I look for what is "left over" from the attempts to use ImageMagick?

        Thanks,

        Paul

        Comment


        • #5
          Suspect File Versions Check produced the folowing suspects:

          activecell.htc
          functions_regimage.php
          cpnav_impex.xml

          Will a reinstall of vBulletin take care of those?

          Thanks,

          Paul
          Last edited by Paul Mayer; Fri 3rd Oct '08, 8:52am.

          Comment


          • #6
            re-install = you loose EVERYTHING.
            So no

            Go to the Admin Control Panel > vBulletin Options > Human Verification
            And change it to the Q+A setting,
            this way the image verification isn't needed, (or change it to GD instead)
            the scripts that break the captcha and recaptcha that came out recently, haven't broken q+a yet. Use creative questions.

            bad: what is 2+2?
            good: If five was one, and you add two, what do you have as total now?

            bad: color of sky?
            good: What would my fathers' brother be to me?

            Comment


            • #7
              With GD I was getting hammered by spammers. The reCAPTCHA has cut that down from 60 a day to zero.

              Is there a way to disable that IM call that is being done as I really think that reCAPTCHA is doing the trick?

              I just got half a dozen of the error emails and am guessing it is the spam bots.

              Thanks,

              Paul

              Comment


              • #8
                Yes, change it to recaptcha, but set the image settings to use gd, not imagemagick.

                Comment


                • #9
                  Originally posted by Floris View Post
                  Yes, change it to recaptcha, but set the image settings to use gd, not imagemagick.
                  Now that's the settings I've had since yesterday and it's driving me crazy.

                  See the two images I attached with my settings.

                  Thanks,

                  Paul
                  Attached Files

                  Comment


                  • #10
                    Then please open a support ticket with ftp and phpmyadmin details, and your forum admin account. Then link to this thread. I will see if I can get a developer to take a look and perhaps find if this is a bug with vb or something else. Put in subject: ATTN Floris: imagemagick issue.

                    Comment


                    • #11
                      The script in your error shows you are trying to use IM:



                      What are you doing when you get that error?
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Originally posted by Steve Machol View Post
                        The script in your error shows you are trying to use IM:

                        What are you doing when you get that error?
                        I'm guessing the errors are being generated when the spam bots are hitting the site. Since I added the line:

                        define('DISABLE_HOOKS', true);

                        It's not happening so far so I'm guessing that disabled whatever is causing it. I hope that does not stop anything else in the forums.

                        Comment


                        • #13
                          Originally posted by Floris View Post
                          Then please open a support ticket with ftp and phpmyadmin details, and your forum admin account. Then link to this thread. I will see if I can get a developer to take a look and perhaps find if this is a bug with vb or something else. Put in subject: ATTN Floris: imagemagick issue.
                          I just told Steve that I think the command define('DISABLE_HOOKS', true); seems to have stopped the error messages.

                          Do you want me to take that back out and submit a ticket?

                          Thanks,

                          Paul

                          Comment


                          • #14
                            If there is a plugin causing this, disable that plugin and turn it back on

                            Comment


                            • #15
                              Originally posted by Floris View Post
                              If there is a plugin causing this, disable that plugin and turn it back on
                              Darn, it happened again so I guess that it is not a plugin.

                              I will submit a ticket as you suggested.

                              Thanks,

                              Paul

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X