Announcement

Collapse
No announcement yet.

Private Group Not Showing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Private Group Not Showing

    Of all my forums, I have a private one that only certain people are allowed access to. I want to say that I've got it set up correctly, but obviously I don't (else it would work).

    Here's the set up:
    1. In order to post to any forum, everyone must register. This is working flawlessly and, upon confirming their email, users are added to the "Registered Users" group.
    2. I have a forum that only some people can see. Let's call it "Special".
    3. Special is set up with "Moderate Posts", "Moderate Threads" and "Show Private Forum" to No.
    4. Under "Posting Options", everything is set to Yes.
    5. I have a user group called "SeeSpecial" and I set them to see the forum under teh "Forum Permissions" screen.
    6. There is a leader for the forum that can process the join requests. In fact, everything is working up to this point.
    7. When I process the requests, the users still cannot see the forum (even after logging out and back in)

    By accepting the request, they are secondary members of the group "SeeSpecial". Do I need to make their primary group "SeeSpecial"? I'd rather just process the request and leave it at that.

    BTW, I am running version 3.7.2 patch level 1

    Thanks!

  • #2
    Make sure their primary group has this enabled:

    Admin CP -> Usergroups -> Usergroup Manager -> Edit Usergroup -> Allow Users to have Member Groups

    Otherwise secondary groups will not affect their permisisons.

    Comment


    • #3
      Thanks Jake!

      But that was already set to yes.

      Comment


      • #4
        Never mind - the "Registered Users" group needed to have that set!

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X