Announcement

Collapse
No announcement yet.

Strange... Flash banner in headers links don't work when in vB's header?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange... Flash banner in headers links don't work when in vB's header?

    Hi,

    This is a strange one. I have a flash banner which has various links within. When on its own or on the main site the links work perfectly. However when I add to the header (see code below) the links don't work. Does vB disable something or...any other ideas?


    header:
    Code:
    <!-- logo -->
    <a name="top"></a>
    <table border="0" width="$stylevar[outertablewidth]" cellpadding="0" cellspacing="0" align="center">
    <tr>
        <td align="$stylevar[left]">
                <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" title="Flash Header" width="770" height="168">
                    <param name="movie" value="http://www.*****.co.uk/img/swf/header.swf">
                    <param name="quality" value="high">
                    <embed src="http://www.*****.co.uk/img/swf/myprotein-header.swf" width="770" height="168" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"></embed>
                </object>
    
    
    </td>
    </tr>
    </table>
    <!-- /logo -->
    <!-- content table -->
    $spacer_open
    
    $_phpinclude_output
    
    $ad_location[ad_header_end]

  • #2
    why do you have two different file names in your object code?

    Comment


    • #3
      Not sure... It has now been removed (see below). However the issue is still not working...any ideas?!

      Header:

      Code:
      <!-- logo -->
      <a name="top"></a>
      <table border="0" width="$stylevar[outertablewidth]" cellpadding="0" cellspacing="0" align="center">
      <tr>
          <td align="$stylevar[left]">
                  <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" title="Myprotein.co.uk Header" width="770" height="168">
                      <param name="quality" value="high">
                      <embed src="http://www.*****.co.uk/img/swf/myprotein-header.swf" width="770" height="168" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"></embed>
                  </object>
      
      
      </td>
      </tr>
      </table>
      <!-- /logo -->
      <!-- content table -->
      $spacer_open
      
      $_phpinclude_output
      
      $ad_location[ad_header_end]

      Comment


      • #4
        Sorry if I mislead you. that object code is suppose to have two calls to the swf file but they are usually the same reference:

        For example:

        Code:
        <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="468" height="60" id="header" align="middle">
                            <param name="allowScriptAccess" value="sameDomain" />
                            <param name="movie" value="http://www.vbplusme.com/images/swf/header.swf" />
                            <param name="quality" value="high" />
                            <param name="bgcolor" value="#ffffff" />
                            <embed src="http://www.vbplusme.com/images/swf/header.swf" quality="high" bgcolor="#ffffff" width="468" height="60" name="header" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
        </object>
        This code displays a flash banner in the header. You code should be similar.


        HTH,

        mikesz

        Comment


        • #5
          Ah ok. I have now changed the header to the below. The links within the flash move are not working, but when accessed directly they work. Have a look at:

          http://forum*myprotein.co.uk

          The flash move direct:

          http://www*myprotein.co.uk/img/swf/myprotein-header.swf

          (please remove the stars above).

          Code:
          <!-- logo -->
          <a name="top"></a>
          <table border="0" width="$stylevar[outertablewidth]" cellpadding="0" cellspacing="0" align="center">
          <tr>
              <td align="$stylevar[left]">
                  
          
          <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="770" height="168"  id="myprotein-header" align="middle">
                              <param name="allowScriptAccess" value="sameDomain" />
                              <param name="movie" value="http://www.myprotein.co.uk/img/swf/myprotein-header.swf" />
                              <param name="quality" value="high" />
                              <param name="bgcolor" value="#ffffff" />
                              <embed src="http://www.myprotein.co.uk/img/swf/myprotein-header.swf" quality="high" bgcolor="#ffffff" width="770" height="168" name="myprotein-header" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
          </object>
          
          
          </td>
          </tr>
          </table>
          <!-- /logo -->
          <!-- content table -->
          $spacer_open
          
          $_phpinclude_output
          
          $ad_location[ad_header_end]

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X