Announcement

Collapse
No announcement yet.

Attachment upload limit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment upload limit

    I need to upload huge files (up to 10 MB) as attachments to be available for download to our registered users.

    Reading through similar post did not solve my problem so far.
    I still can't upload a bigger file. There seems to be somewhere a limitation which I would define as 1 MB based on the upload bar graphics within my attachments.

    I configured php.ini to accept up to 20MB.
    vBulletin attachments are set to 20MB.

    What else I have to do to be able to upload bigger files? Any hidden switch within vBulletin which I didn't notice?

    Thanks

  • #2
    In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf (or my.ini for Windows systems)

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Note: Do NOT use MB, just M for the megabytes setting.

    You may also need to increase the memory_limit, max_execution_time and max_input_time variables in php.ini.

    Also you might want to take a look at this for other settings that affect file uploads:

    http://www.vbulletin.com/forum/showp...0&postcount=12
    http://www.vbulletin.com/forum/showt...319#post748319

    Comment


    • #3
      Thanks for the reply.

      Unfortunately the only thing I can change on my server is the "upload_max_filesize" via a .htaccess file.
      I increase the value, however I am still unable to upload files bigger that 1 MB.

      My hoster does not allow to access "my.cnf".

      My current settings:
      PHP max post size: 8MB
      PHP maximum uload size: 60MB
      PHP memory limit: 32MB
      MYSQL packet size: 16 MB

      Can anybody help? I don't want to drop vBulletin for a free forum software which accepts big uploads without problems
      Thanks

      Comment


      • #4
        Honestly this is a server issue and Kerry-Anne's post is still applicable. I'm afraid you are at the mercy of your host for this one.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I had same problem and solved it creating a folder on www to move attachments there.
          Then on attachment storage type, i transferred all to that folder, out of Mysql.

          Never had an uploading problem since.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X