Announcement

Collapse
No announcement yet.

Smilies problem in WYSIWYG

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Smilies problem in WYSIWYG

    I am having a problem with the smilies in WYSIWYG editor. I have tried to seach the forums on this, but due to the quote in it, I can't pinpoint it.

    I did search in my phrases and did not find the case, so I have brought it here to ask where the problem might be.

    Specifically Smilies"> is shown above the smilie as shown in my attachment.

    Thank you kindly.
    Attached Files
    www.karmicpower.com
    online community of like minded people

    be the change you wish to see in the world

  • #2
    Try this. Create a new style and choose no parent style. This will force it to use the default templates. Then change to this style and view your forums with it. Do you have the same problem?

    If you do, empty your browser cache, close all browser windows and try again.

    If you do not have this problem with the original templates, then this means the problem is with one or more of your custom templates. You need to revert your templates, then redo your changes.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hi Steve

      After each change I have made here, the cache was cleared and browser restarted.

      I imported the default style choosing new style, no parent and named it. It just imported as the default style. I have been working exclusively with the default style.

      I then reverted the template of which there were 6 editor_styles templates. I did a search for the templates and none were shown, I was quite puzzled.

      I then reverted those templates but they do not show up in the style. I went again to Revert Templates and it said nothing to do.

      I looked at the default style xml and I see that those templates do exist in it.

      I then tried to create the editor_styles_button_down as a test entering the information that is in the xml. Once I saved it, it still did not show up in the template list and searching for the name editor_styles_button_down produced no results. I then went and reverted templates and it stated only editor_styles_button_down and reverted it. Still it is not showing up in the template list.


      When I worked with my custom style the same templates were missing and searching for them produced no results as well. I looked in the custom xml file and those templates are not in there, so should not be affecting the default templates. I also ensured that none of the editor_ templates had been changed. I then tried to create the same template in the custom style and it did not work. I looked at the files to revert and the only related editor_styles template was editor_styles_button_down which I had created, same as the default style.


      I have gone into my database and I see that the templates are there. I also see the two editor_styles_button_down templates that I had created as tests. Once they were reverted the only editor_styles_button_down entry is the default.

      I searched the entire database for the phrase Smilies"> and had zero results.


      I'm not sure where to go now. Obviously there is some reason why the templates are not showing.

      Thanks for your help
      Attached Files
      www.karmicpower.com
      online community of like minded people

      be the change you wish to see in the world

      Comment


      • #4
        No, do not import the default style. Create a new one.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Hi Steve

          I have gone through the process of importing a new style, sorry if I didn't make it clear in the above post.

          I have attached screenshots to show what isn't happening. I have chosen to create a new style with no parent style and gave it the name Testing Style.

          The page refreshes and I get the Importing Style please wait and it flashes Master File. The page refreshes again and I get to Rebuild Style information that shows only the Default Style and my custom style. The new Testing Style did not get created. When I got back to the Style Manager there is only the Default and Custom and no Testing Style.

          Screenshots attached, if I am blatantly doing something wrong, please let me know.

          Thanks
          Attached Files
          www.karmicpower.com
          online community of like minded people

          be the change you wish to see in the world

          Comment


          • #6
            As I said do not import the default style. Create a new one.

            Admin CP -> Styles & Templates -> Style Manager -> Add New Style
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Thanks Steve for the correction.

              Created a new style, checked to see that there was nothing to revert, those same templates are missing and the problem still exists.
              www.karmicpower.com
              online community of like minded people

              be the change you wish to see in the world

              Comment


              • #8
                Then this means another modification you made is causing this. Did you edit any vB phrases?

                To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                Next, disable all plugins.

                Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                define('DISABLE_HOOKS', true);
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Thank you Steve!

                  I searched in the phrases for Smilies and saw that another admin had added a font tag with an improper color code which resulted in the "> being displayed. Once I removed that tag, the problem was fixed!

                  Greatly appreciate your help!
                  www.karmicpower.com
                  online community of like minded people

                  be the change you wish to see in the world

                  Comment


                  • #10
                    Glad to hear it.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Interesting to note is that those editor_styles templates are still not present. I guess as long as I don't have to edit them, all is good
                      www.karmicpower.com
                      online community of like minded people

                      be the change you wish to see in the world

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X