Announcement

Collapse
No announcement yet.

How to Download a complete style including CSS code?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to Download a complete style including CSS code?

    Hello,

    I am trying to download a style that I have added a lot of custom code and themplates. When I use the Download Style, for some reason, about half of the CSS code goes missing or does not get imported if I try to restore it, no idea why?

    Here is what I am doing.

    I take an existing style and import it. Every thing works and the Main CSS page is fully populated with what ever it is suppose to have.

    I customize the style and download it. Then I delete the style and try to import my downloaded version expecting that every thing will just work.

    When I do the import, the custom CSS code is missing, though I see it in the .xml file, it is not being imported into the Style Manager.

    Any Ideas how I fix this? It is a pretty flakey backup system if that is the way it works. Either that or I am not understanding how it works.

    Really appreciate some light being shed on this one.

    TIA,

    mikesz

  • #2
    Are any of the CSS changes contained in a parent style? When downloading a style it gives you the option to download customizations in the child only or in all parent styles as well.

    Comment


    • #3
      thanks for the reply

      Hello Jake,

      I installed the style on the same level as the default and named it mydefault. I also reinstalled the style with its original name with the same results, the css customizations go missing. At first I thought was only the customization in the "bottom" box on the CSS screen but when I checked the individual class definitions, about half of them were missing too, mostly the ones that contained a background/image url for the background tag.

      re: parent/child, I did it both ways with the same result.

      I was working first with the minty green style but I notice the same issue with other styles I have now tested.

      Any suggestions about how to further troubleshoot?

      thanks, mikesz

      Comment


      • #4
        I don't know why it would be doing that. I can take a look if you submit a trouble ticket with your forum and server info:

        http://members.vbulletin.com/members...ontactform.php

        Comment


        • #5
          Thanks Jake...

          I have just now submitted the ticket.

          Thanks for the help.

          mikesz

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X