Announcement

Collapse
No announcement yet.

forum is on private help please asap!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • forum is on private help please asap!

    hello i have reset all permissions to view my forum, but it is still on private and guests cant view the threads. it just says private. i even allow guests to view threads and forum is still on private how do i let guests view my threads.


    hello when a guest is on my site the threads are not shown it says private and when they click it just shows up an empty forum why cant my guests view any threads in my forum how do i fix this?
    Last edited by husky1; Fri 1 Aug '08, 6:30pm.

  • #2
    Check the overall Usergroup permissions:

    Admin CP -> Usergroups -> Usergroup Manager -> Edit Usergroup

    And the Forum permissions for each forum and Usergroup:

    Admin CP -> Forums & Moderators -> Forum Permissions

    Main Usergroup Permissions take precedence unless you override them with specific Forum/Usergroup permissions.

    When multiple usergroups are involved, a 'Yes' permission always overides a 'No' permission if 'Allow Users to have Member Groups ' is set to 'Yes' for the Primary group. Same goes for a larger quota.

    Note, the primary group must have 'Allow Users to have Member Groups' to 'Yes'. Otherwise the secondary settings are not applicable.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      hello friend, both are set to yes and i still have this issue.

      can view forum = yes

      Comment


      • #4
        If all the permissions are set correctly, then the only other possibility is that a modification is causing this.

        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all plugins.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          ^ i dont know how to do all this stuff
          Last edited by husky1; Fri 1 Aug '08, 7:50pm.

          Comment


          • #6
            its ok i fixed this i didnt enable view thread content! thanx anyway

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X