Announcement

Collapse
No announcement yet.

headers already sent bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • headers already sent bug

    Warning: Invalid argument supplied for foreach() in [path]/private.php on line 786

    Warning: Invalid argument supplied for foreach() in [path]/private.php on line 786

    Warning: Invalid argument supplied for foreach() in [path]/private.php on line 786

    Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:3243) in [path]/includes/functions_file.php on line 147

    Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:3243) in [path]/includes/functions_file.php on line 148

    Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:3243) in [path]/includes/functions_file.php on line 149

    Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:3243) in [path]/includes/functions_file.php on line 150

    Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:3243) in [path]/includes/functions_file.php on line 151

    Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:3243) in [path]/includes/functions_file.php on line 152
    I just clicked on "Export private messages as - text" and got these errors on the page.
    ( /forum/private.php?do=downloadpm&dowhat=txt )

  • #2
    How many PMs do you have? I remember getting a similar problem a while back.

    Comment


    • #3
      Originally posted by Kinneas View Post
      How many PMs do you have? I remember getting a similar problem a while back.
      828 messages.

      Comment


      • #4
        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions


        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all plugins.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

          Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions


          [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

          Next, disable all plugins.

          Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

          define('DISABLE_HOOKS', true);

          Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
          I do...

          Comment


          • #6
            Which version of vB are you running and what is the URL?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol View Post
              Which version of vB are you running and what is the URL?
              www.consolediscussions.com

              VB 3.7.3 Patch Level 1

              Comment


              • #8
                This is a highly modified forum which includes third-party add-ons:

                http://www.consolediscussions.com/forum/

                Please follow the steps in post #4.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  This is a highly modified forum which includes third-party add-ons:

                  http://www.consolediscussions.com/forum/

                  Please follow the steps in post #4.
                  I did follow those steps. I disabled all of my plugins and still the error occurs.

                  Comment


                  • #10
                    You still have add-ons installed and running. This is a problem caused by a modification. We cannot provide support for forums running third-party code.

                    Also this is not your thread. For further help please start your own thread with all the relevant details. Thank you.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Why start a new thread for the exact same issue? I don't understand how disabling all modifications can still make my modifications enabled.

                      Comment


                      • #12
                        Because:

                        1. It's rarely the 'exact same issue'.

                        2. As an Admin of this forum I asked you to.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X