what's Problem ?

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • alishahbazi
    Member
    • Jul 2008
    • 36
    • 3.7.x

    what's Problem ?

    hi ,
    before i Use Warez HOST , BUT i sale License vbulletin.
    i am download vbulletin & Upgrade the vbuletin but During change THEME viwe ing this eror :::::

    Required variables have gone missing and execution can not continue. Please try again.

    This error can sometimes occur as a result of Suhosin / Hardened PHP being installed on your server. If you know that you have Suhosin running and you have access to the PHP configuration, try increasing the value of the following variables:
    • php_value suhosin.post.max_vars
    • php_value suhosin.request.max_vars
    please Help me !
    THX ( ALI )
  • Steve Machol
    Former Customer Support Manager
    • Jul 2000
    • 154488

    #2
    The most likely cause of this problem is the suhosin module in PHP. If so this can be fixed by editing the php.ini (requires root access to the server) or by via a .htaccess file with the following contents:

    php_flag suhosin.cookie.encrypt Off
    php_value suhosin.request.max_vars 2048
    php_value suhosin.post.max_vars 2048

    You can create your own .htaccess file and upload it to your main forum directory. It's a simple text file.

    If this doesn't work or you get an 'Internal Server Error' after doing this, then unfortunately this means that your host is not allowing this change. The only thing you can do now is to ask your host to make the necessary changes to suhosin.

    Here is a post that lists some of the recommended suhosin settings for compatibility with vB:

    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    • Danial_Faster
      Senior Member
      • May 2008
      • 134
      • 3.7.x

      #3
      Depending on the page with the error you might need to change the following using a suggested value of 1024 or 2048 for NewValue in .htaccess:
      Code:
      php_value suhosin.request.max_vars NewValue
      php_value suhosin.post.max_vars NewValue

      And otherwise try :
      php_flag suhosin.cookie.encrypt Off


      If this all doesn't work, it has to be done via php.ini

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      😀
      😂
      🥰
      😘
      🤢
      😎
      😞
      😡
      👍
      👎