Announcement

Collapse
No announcement yet.

Cannot Log Database Errors to a File

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot Log Database Errors to a File

    Okay... I am trying to have Database Errors, Failed ACP Login Attempts, and PHP Errors logged to a file in a folder on my server.
    I created the folders directly below my 'forums' directory and CHMOD'd it as 777.

    So I have:
    /forums/errorlogs/dberrors
    /forums/errorlogs/phperrors
    /forums/errorlogs/acplogins
    (Like I said above - all are CHMOD 777).

    I have a messed up modification that if I choose a certian option with it, it gives me a DB Error. That isn't my concern, but I used that to test what I am trying to do.

    For some reason, it just isn't working. I am getting the E-mail regarding the DB error, but it just isn't being logged to the folder.
    I have tried a few different things in the area to specify a path.

    Here is all I've tried:

    /lineolatedparakeet.net/forums/errorlogs/dberrors

    /home/users/public_html/forums/errorlogs/dberrors

    /home/ec*****ork/lineolatedparakeet.net/forums/errorlogs/dberrors
    (I only just used the asterisks for privacy).

    hsphere/local/home/ec*****ork/lineolatedparakeet.net/forums/errorlogs/dberrors

    It doesn't work with any of those.
    Any idea as to why? Or what I need to enter?

    Thanks so much in advance for any help
    Regards,
    Nick

  • #2
    Thought of just turning off email that sends error to?

    vBulletin Options > vBulletin Options > Error Handling & Logging > Disable Database Error Email Sending

    Comment


    • #3
      Originally posted by Jose Amaral Rego View Post
      Thought of just turning off email that sends error to?

      vBulletin Options > vBulletin Options > Error Handling & Logging > Disable Database Error Email Sending
      Well it doesn't say I have to turn that setting off... but I will try it.

      However, I don't know which is the appropriate path to specify, of those listed above.
      Regards,
      Nick

      Comment


      • #4
        This is not a valid path:

        /forums/errorlogs/dberrors

        Use the full and complete path to the directory containing your backup. On Unix/Linux systems you can find the complete path name by telnetting or sshing into your server, going to that directory and typing:

        pwd
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Unfortunately I do not have SSH or Telnet access (as per my host).

          And what do you mean it's not a valid path? Do you mean it's 'not acceptable' or are you saying it doesn't exist on my server?
          Because it does exist on my server.
          Http://www.lineolatedparakeet.net/fo...rlogs/dberrors

          It's just blank because I uploaded a blank index.php file.
          Regards,
          Nick

          Comment


          • #6
            It's not valid because I'm certain there is no root 'forums' directory on that server. Besides if it were valid, it would work.

            Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

            Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              http://www.lineolatedparakeet.net/forums/
              Regards,
              Nick

              Comment


              • #8
                Your document root is:

                /hsphere/local/home/ecnetwork/lineolatedparakeet.net

                Therefore assuming those are subdirectories of your forum directory. the correct paths would be:

                /hsphere/local/home/ecnetwork/lineolatedparakeet.net/forums/errorlogs/dberrors
                /hsphere/local/home/ecnetwork/lineolatedparakeet.net/forums/errorlogs/phperrors
                /hsphere/local/home/ecnetwork/lineolatedparakeet.net/forums/errorlogs/acplogins
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Like I posted in my first post, I tried that one already.

                  However, when I look back I see I might have missed the beginning slash...
                  So I just tried again, yet still no dice.

                  I'm positive the directory names are created, with those exact names, and permissions are set to 777.
                  Regards,
                  Nick

                  Comment


                  • #10
                    The slash makes all the difference.

                    Log out of FTP, what until you are sure you have some activity that should be logged, then check the log files again.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      If the dberrors phperrors and acplogins are directories then you need to add /filename to the end of these paths. Do not add .log to the file name or create the file.

                      The format should be /server_path/logs_directory/log_file_name

                      The logs_directory must be CHMod 777.
                      Kerry-Anne :)

                      Twitter Blog

                      www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

                      Comment


                      • #12
                        Thanks Kerry-Anne.

                        I found from another thread that I need to add the filename to the end of the directory and it worked.
                        Regards,
                        Nick

                        Comment


                        • #13
                          Originally posted by Steve Machol View Post
                          This is not a valid path:

                          /forums/errorlogs/dberrors

                          Use the full and complete path to the directory containing your backup. On Unix/Linux systems you can find the complete path name by telnetting or sshing into your server, going to that directory and typing:

                          pwd
                          When you do this and get your directory and enter the directory in the adminCP do you stop with only the directory? Or do you add the file name .log also

                          example:
                          /home/name/public_html/forums/mydir
                          OR
                          /home/name/public_html/forums/mydir/
                          OR
                          /home/name/public_html/forums/mydir/dblogs.log
                          Last edited by Zoro; Thu 30 Oct '08, 1:41am.

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X