Announcement

Collapse
No announcement yet.

Database Error on Registration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database Error on Registration

    Dear All,

    I have a problem, when people register on my forum and go through the registration process at the end it directs to


    Can someone help why this is?

    Thanks

    The site is http://forums.retrowheels.org

  • #2
    Originally posted by Retro View Post
    Dear All,

    I have a problem, when people register on my forum and go through the registration process at the end it directs to


    Can someone help why this is?

    Thanks

    The site is http://forums.retrowheels.org
    No help then

    Comment


    • #3
      Please wait at least 12 hours before bumping your posts.

      From the forum rules:
      http://www.vbulletin.com/forum/showthread.php?t=42918

      Please wait a reasonable amount of time before bumping posts. For style changes and general 'how-to' questions this should be 24 hours. For specific troubleshooting issues, use 12 hours as a guideline.
      We need to see the real error message. Right-click on the error page and go to View/Source. Then copy-n-paste the error message here.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Here is the code below, My apologies for bumping thread
        Code:
        <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
        <html>
        <head>
            <title>Retro Wheels Database Error</title>
            <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
            <meta name="ROBOTS" content="NOINDEX,NOFOLLOW,NOARCHIVE" />
            <style type="text/css">
            <!--    
            body { background-color: white; color: black; }
            #container { width: 400px; }
            #message   { width: 400px; color: black; background-color: #FFFFCC; }
            #bodytitle { font: 13pt/15pt verdana, arial, sans-serif; height: 35px; vertical-align: top; }
            .bodytext  { font: 8pt/11pt verdana, arial, sans-serif; }
            a:link     { font: 8pt/11pt verdana, arial, sans-serif; color: red; }
            a:visited  { font: 8pt/11pt verdana, arial, sans-serif; color: #4e4e4e; }
            -->
            </style>
        </head>
        <body>
        <table cellpadding="3" cellspacing="5" id="container">
        <tr>
            <td><img src="http://forums.retrowheels.org/image.php?type=dberror" alt="Database Error" width="48" height="48" /></td>
            <td id="bodytitle" width="100%">Database error</td>
        </tr>
        <tr>
            <td class="bodytext" colspan="2">The Retro Wheels database has encountered a problem.</td>
        </tr>
        <tr>
            <td colspan="2"><hr /></td>
        </tr>
        <tr>
            <td class="bodytext" colspan="2">
                Please try the following:
                <ul>
                    <li>Load the page again by clicking the <a href="#" onclick="window.location = window.location;">Refresh</a> button in your web browser.</li>
                    <li>Open the <a href="/">forums.retrowheels.org</a> home page, then try to open another page.</li>
                    <li>Click the <a href="javascript:history.back(1)">Back</a> button to try another link.</li>
                </ul>
            </td>
        </tr>
        <tr>
            <td class="bodytext" colspan="2">The forums.retrowheels.org forum technical staff have been notified of the error, though you may <a href="mailto:[email protected]">contact them</a> if the problem persists.</td>
        </tr>
        <tr>
            <td class="bodytext" colspan="2">&nbsp;<br />We apologise for any inconvenience.</td>
        </tr>
        </table>
        
        
        <!--
        Database error in vBulletin 3.7.2:
        
        Invalid SQL:
        INSERT INTO userlist (userid, relationid, type, friend) VALUES (17, , 'buddy', 'yes');
        
        MySQL Error   : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 'buddy', 'yes')' at line 1
        Error Number  : 1064
        Request Date  : Sunday, July 6th 2008 @ 10:57:04 AM
        Error Date    : Sunday, July 6th 2008 @ 10:57:05 AM
        Script        : http://forums.retrowheels.org/register.php?do=addmember
        Referrer      : http://forums.retrowheels.org/register.php?do=register
        IP Address    : 78.145.175.200
        Username      : admin
        Classname     : vB_Database
        MySQL Version : 
        -->
        
        
        </body>
        </html>

        Comment


        • #5
          SQL Syntax errors are almost always related to modified code.

          To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

          Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

          [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

          Next, disable all plugins.

          Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

          define('DISABLE_HOOKS', true);


          Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Then make this the default style:

          Admin Control Panel -> vBulletin Options -> Style & Language Settings -> Default Style

          You should not have this problem after that.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            This is now working fine,

            Much appreciated Steve


            Regards
            Steve

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X