Announcement

Collapse
No announcement yet.

Login problem after moving to new server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Login problem after moving to new server

    Hi
    I have moved my site from a host to a new server (the same hosting service). When I log in, it shows me the "successful login" page but then it moves me to the same page that I was before loging in, while I'm not really loged in.
    If I check the "remember me" box, then I can log in as normal.

    Any ideas on how to solve this problem? Thanks.

  • #2
    If 'Remember me' works then this may be due to you ISP. This is because many ISPs, such as AOL but not limited to them, change the IP address with almost every click which logs them out unless you are using cookies.

    Nonetheless try this. Upload the tools.php script in the 'do_not_upload' folder of the vB zip file to your Admin CP directory and run it from your browser. Use this to reset the cookie domain and path back to the defaults. And then leave your cookie domain and path at the default settings. There is no reason to change these. If you need to specify a unique cookie, use the cookie prefix setting in config.php instead.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by RFViet View Post
      Hi
      I have moved my site from a host to a new server (the same hosting service). When I log in, it shows me the "successful login" page but then it moves me to the same page that I was before loging in, while I'm not really loged in.
      If I check the "remember me" box, then I can log in as normal.

      Any ideas on how to solve this problem? Thanks.

      I had this same trouble. Even after completly clearing my cookies and cache, it still happened.

      I edited my config.php file and changed the cookie prefix to something entirely different. It then worked fine.

      Not sure why, but it seems that the old cookie prefix did not match the new server in some way or another.. But changing the cookie prefix fixed it for me.

      Comment


      • #4
        Originally posted by Steve Machol View Post
        If 'Remember me' works then this may be due to you ISP. This is because many ISPs, such as AOL but not limited to them, change the IP address with almost every click which logs them out unless you are using cookies.

        Nonetheless try this. Upload the tools.php script in the 'do_not_upload' folder of the vB zip file to your Admin CP directory and run it from your browser. Use this to reset the cookie domain and path back to the defaults. And then leave your cookie domain and path at the default settings. There is no reason to change these. If you need to specify a unique cookie, use the cookie prefix setting in config.php instead.

        Here is what I got after running tools.php . I place "..." to hide my foder names on the server . Do I have to edit the tools.php file ??
        Warning: require_once(./install/init.php) [function.require-once]: failed to open stream: No such file or directory in /home/..../public_html/.../.../tools.php on line 43

        Fatal error: require_once() [function.require]: Failed opening required './install/init.php' (include_path='.:/usr/local/php5/lib/php') in /home/.../public_html/.../.../tools.php on line 43

        Comment


        • #5
          That is because you have removed the install directory and/or it's files. Reupload all the files except install.php.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            That fixes my problem, thanks.

            Comment


            • #7
              Sorry, I thought that fixed the problem, but it is not really. When I restarted my PC, the problem is still there. Any other idea ??

              Comment


              • #8
                You can't get that same error if you uploaded all the files. What is the new error?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  You can't get that same error if you uploaded all the files. What is the new error?
                  There is no error. I was able to run tools.php but it still doesn't fix the problem by resetting the cookies and set the path back to the default.

                  Comment


                  • #10
                    Then what is the exact problem now? We will need to know this in order to help.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      I had this problem and fixed it by reinstalling vbulletin
                      http://www.acegames.us http://www.crazywap.co.uk

                      Comment


                      • #12
                        Originally posted by RFViet View Post
                        Hi
                        I have moved my site from a host to a new server (the same hosting service). When I log in, it shows me the "successful login" page but then it moves me to the same page that I was before loging in, while I'm not really loged in.
                        If I check the "remember me" box, then I can log in as normal.

                        Any ideas on how to solve this problem? Thanks.
                        This is the problem.

                        Comment


                        • #13
                          are you using the same url that you were using before, or a different 1?

                          http://forum.yourdomain.com
                          http://forum2.yourdomain.com

                          Just wondering, because I had a looping issue too (using 2 domain names) and I went in and to VB Options > Cookies & Header Options > Cookie domain and instead of / (which is the default) I chose .mydomain.com

                          ( I left the path to Save Cookies at the default settings)

                          and the looping stopped.

                          Comment


                          • #14
                            Originally posted by Budget101 View Post
                            are you using the same url that you were using before, or a different 1?

                            http://forum.yourdomain.com
                            http://forum2.yourdomain.com

                            Just wondering, because I had a looping issue too (using 2 domain names) and I went in and to VB Options > Cookies & Header Options > Cookie domain and instead of / (which is the default) I chose .mydomain.com

                            ( I left the path to Save Cookies at the default settings)

                            and the looping stopped.
                            Yes, I'm using the same url before.

                            Comment


                            • #15
                              This worked for me too.

                              Originally posted by redtailboas View Post
                              I had this same trouble. Even after completly clearing my cookies and cache, it still happened.

                              I edited my config.php file and changed the cookie prefix to something entirely different. It then worked fine.

                              Not sure why, but it seems that the old cookie prefix did not match the new server in some way or another.. But changing the cookie prefix fixed it for me.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X