Announcement

Collapse
No announcement yet.

vbupload files in forum root dir?

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vbupload files in forum root dir?

    Since the update to 3.7.1 i see my forum is generating these upload files in the forum root dir.

    vbuploadSau3J1
    vbuploadQWI7Y3
    vbupload9fOrQ9
    ...

    There are more of this files.
    What can i do?

    The server is not in safe mode.
    /tmp is working fine.

  • #2
    There is a very old bug here:
    http://www.vbulletin.com/forum/project.php?issueid=2524

    You should be able to simply delete them.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Ok, deleted them.

      But when i reproduce it

      At profile.php?do=editavatar, under Profile Picture, enter the URL of an image which exceeds the size limit. It'll tell you "That image is too large." Then, if you check /tmp you'll find the image you uploaded.
      i find new files in my forum root.

      I was searching for the functions_upload.php but is seems that it don't exists anymore in vbulletin 3.7.1.

      Originally posted by Freddie Bingham
      See if this fixes the problem.

      edit includes/functions_upload.php

      Place this code:

      @unlink($filename);

      Before the following lines:

      (1) eval(print_standard_error('error_imagebaddimensions'));
      (2) eval(print_standard_error('error_imagenotimage'));
      (3) eval(print_standard_error('error_imagenotimage'));
      (4) eval(print_standard_error('error_imagetoobig'));

      The line for (2) and (3) appears twice.

      Comment


      • #4
        Originally posted by Fred. View Post
        Since the update to 3.7.1 i see my forum is generating these upload files in the forum root dir.

        vbuploadSau3J1
        vbuploadQWI7Y3
        vbupload9fOrQ9
        ...

        There are more of this files.
        What can i do?

        The server is not in safe mode.
        /tmp is working fine.
        Running vB 3.7.2
        I have the same issue with that files in my forums root.
        You have posted a change in functions_upload.php

        Seems like that file does not exist anymore in vB 3.7.2

        How can I fix this vbupload* issue?

        Thanx for advice.
        file

        Comment


        • #5
          Those are not vB files. If you need further help please start your own thread with all the relevant details. Thank you.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I can't find a solution for this. I delete a few hundred files daily.
            I don't know why vbulletin generate this files in the forum root dir. they belong in /tmp

            My forum still runs on PHP 4.4.2
            I plan to upgrade within a few months to php 5.2

            Comment


            • #7
              vB should not be generating those files - at least not the default vB. My guess is that this is either a problem with an add-on, or the server is creating these temp files.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Ok, i have the follow plugins installend.

                Advanced BBCode Permissions 3.0
                All Albums 2.3
                Archive Adsense 1.0
                Google Ads by Mastar 2.0.3
                Image Resizer 1.0.2
                Statistics 3.1
                User Countdown 1.13
                vBSEO 3.2.0
                vBSEO :: Sitemap Generator 2.1

                Maybe Cocko has one of this plugins too, so we can find the problem.
                I hope to find the problem soon.

                Comment


                • #9
                  I've spotted three such files - I have the following mods:

                  All Albums
                  Album Pictures - Forum Home
                  Is Bot
                  Report Bad Pm

                  Can't see why the mods would leave temp upload files as none of them should include upload functions.

                  Comment


                  • #10
                    Hi vord,

                    All Albums is not the problem.
                    my forum was generating those files before i installed All Albums.

                    which version of php have you installed?

                    Comment


                    • #11
                      PHP 5.2.5 on Linux running Apache with FastCGi. Spotted them after upgrading to 3.7.2 PL2.

                      Though I've not noticed any more appear after my last post, and there are none on another forum on the same server with the same setup.

                      One thought after a really quick read of the bug Waybe Luke linked - there are problems with big image uploads on this server - upload page goes blank rather than the appropriate GD resizing error. Could be to do with that.

                      Comment


                      • #12
                        Originally posted by vord View Post
                        One thought after a really quick read of the bug Waybe Luke linked - there are problems with big image uploads on this server - upload page goes blank rather than the appropriate GD resizing error. Could be to do with that.
                        Blank pages most often indicate a PHP Error as production servers should have displaying errors turned off. In this case it could be a memory allocation error. Having a script fail in the middle could cause this. The files would only be there however if your temporary directory is set to your vBulletin forum directory. This should not be the case on a production server either.

                        I'd try allocating more memory to PHP to make it 32-64 MB.

                        Please see this for all the known causes of blank or 'white' pages:
                        http://www.vbulletin.com/docs/html/blank_pages
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API - Full / Mobile
                        Vote for your favorite feature requests and the bugs you want to see fixed.

                        Comment


                        • #13
                          Thanks Wayne, I didn't mean to seek advice on my blank screen error as I'm in the process of moving servers to sort out packet loss and support problems. I don't get the error on the new server, just a proper vBulletin message saying we can't deal with images this size (which I assume is the GD image size limitation for re-sizing).

                          Good link though for others searching for the trouble that don't need to move servers for packet loss reasons.

                          Comment


                          • #14
                            I get the vbupload* files all the time. Running 3.8.1

                            Comment


                            • #15
                              I just upgraded to 3.8 and just today, I started getting these files in my ./forum directory. They are are all zero byte length. What is the deal? ANy ideas?
                              Thank You...Mick Knutson

                              BLiNC Magazine Forums: "Everything you ever wanted to know about BASE-Jumping, but didn't know whom to ask."

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X