No announcement yet.

Error on page: 'null' is null or not an object

  • Filter
  • Time
  • Show
Clear All
new posts

  • Error on page: 'null' is null or not an object

    I have just upgraded to 3.7.1 and get this strange error on some of my pages, for example this one:

    The error is an "Error on page" error.

    Line: 12
    Char: 21884
    Error: 'null' is null or not an object
    Code: 0

    What is strange is that when I look in the code in line 12, there is no code, just an empty line. Look below:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "[URL][/URL]">
    <html xmlns="[URL][/URL]" dir="ltr" lang="en">
     <!-- BEGIN TEMPLATE: headinclude -->
    <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
    <meta name="generator" content="vBulletin 3.7.1" />
    <meta name="keywords" content=" TMS - wrong systems settings - localdn, video conferencing, videophones, multipoint videoconferencing, video teleconferencing polycom videoconferencing video conferencing system PacketMaster Easy vc-107 telemedicine sony pcs-1 sony contact 1600 t.120 ptz camera videoconference lights video telephone educational videoconferencing bridge viewstation h.323" />
    <meta name="description" content=" TMS - wrong systems settings - localdn Management Systems" />
    <!-- CSS Stylesheet -->
    <style type="text/css" id="vbulletin_css">
    * vBulletin 3.7.1 CSS
    * Style: 'VTCTALK CUSTOM'; Style ID: 2
     background: #FFFFFF;
     color: #000000;
     font: 8pt verdana, geneva, lucida, 'lucida grande', arial, helvetica, sans-serif;
     MARGIN-TOP: 0px;
     MARGIN-BOTTOM: 0px;
     MARGIN-LEFT: 0px;
     MARGIN-RIGHT: 0px; 
     scrollbar-base-color: #f2f2f2; 
     scrollbar-track-color: #f9fafa;
     scrollbar-face-color: #F1F1F1;
     scrollbar-highlight-color: #ffffff;
     scrollbar-3dlight-color: #ffffff;
     scrollbar-darkshadow-color: #ffffff;
     scrollbar-shadow-color: #C8C8CA;
     scrollbar-arrow-color: #999999;
    a:link, body_alink
     color: #000020;
    a:visited, body_avisited
     color: #000020;
    a:hover, a:active, body_ahover
     color: #FF4400;
    I have tried to compare with other pages that does not have the error. Pages that have almost identical code for the first 50 lines.
    So is this error really in line 12, or am I looking somewhere wrong? Also, it says character 21884 which sounds quite high to me - expecially since there is no charactes in line 12. Any ideas?


  • #2
    Reaupload and overwrite all non-image files and try to upgrade again.
    vBProjects - Professional vBulletin Services and Solutions
    vBSpring - Premium vBulletin Add-ons


    • #3
      I would very much not prefer to do this since that will take a long time in terms of redoing settings and customizations and for all I see the problem could as easily persist after that.

      Isn't there some way of finding the actual reason to the problem? Any ideas what this line/character error indication suggests?



      • #4
        If you have just upgraded, then no more customization you will do. Settings can't be changed after upgrade. If your problems appear after upgrade, then they are caused by wrong upgrade, so my suggestion is to try again.
        vBProjects - Professional vBulletin Services and Solutions
        vBSpring - Premium vBulletin Add-ons


        • #5
          Yes, I agree that the problem is most probably caused by the upgrade and most probably because I am using customized templates (customized design). I had several smal problems because I didn't revert all templates but they have all been solved except this last problem.

          So what I am really curious to know is what this error is related to, and how there can be an error in line 12 when there is no code in line 12. Anyone?



          • #6
            So, just in case there should be any other poor bastards like me out there that has custom designs that doesn't allow one to 100% revert all templates after updates - AND has this java error above, I found out what removed the problem for me. This particular error went away after I reverted the navbar template - it also messed up a little graphics in the bottom of the page, but that can be fixed later on.

            Ok, that's all from me...


            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.