Announcement

Collapse
No announcement yet.

can't access two sections of the forum...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • can't access two sections of the forum...

    We just finished our import yesterday over from phpbb2. Everything has gone great, except two areas of the forum...

    The admin section: We can see it. We can click on it, but when we do it just refreshes the page. I've checked the permissions 20 times and they are set correctly.

    Same thing with another section. We can see it. Click on it, but the page just refreshes. How do you fix this?

  • #2
    First, make sure your user really is an Admin.

    Then this is probably a cookie domain/path issue. To fix this, upload the tools.php script in the 'do_not_upload' folder of the vB zip file to your Admin CP directory and run it from your browser. Use this to reset the cookie domain and path back to the defaults. And then leave your cookie domain and path at the default settings. There is no reason to change these. If you need to specify a unique cookie, use the cookie prefix setting in config.php instead.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      This is what I'm at right now...

      So I don't think it's cookies.

      Cookie Prefix bb (set in includes/config.php)
      [Reset Cookie Domain] Reset the cookie domain to be blank
      Currently: ( blank )

      [Reset Cookie Path] Reset the cookie path to be /
      Currently: /

      Comment


      • #4
        Is that user in the Administrators usergroup as per 'Show Forum Leaders'?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          The user is me the main admin on the board, but none of the other admins can see it as well.

          The other section we are having the same problem with is open the to the public and they can't access that either. The section shows up and you can click on it. Then it just refreshes the forum...

          Any help is greatly appreciated. We really need to get access to this admin section as it has a lot of information we used from the phpbb forum.

          Comment


          • #6
            Does your user show on the 'Show Forum Leaders' page as an Administrator?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol View Post
              Does your user show on the 'Show Forum Leaders' page as an Administrator?
              yes.

              Comment


              • #8
                Then either:

                a. You are blocking cookies (you need to enable cookies in order to access the Admin CP,

                and/or

                b. You have not uploaded all the original vB files, in particular the files for the admincp directory.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  Then either:

                  a. You are blocking cookies (you need to enable cookies in order to access the Admin CP,

                  and/or

                  b. You have not uploaded all the original vB files, in particular the files for the admincp directory.
                  Oh not I'm not trying to access the AdminCP that works fine. I'm talking about a separate section in the forum where only the administrator have access to. So we can talk about what's going on in private.

                  Here is a screenshot...



                  I had to make the administrator section so we could use that temporarily. However I'm trying to access the 'Admin' section. It transfered over from the old forum, but when we click on it. We get this screen.



                  You can click on admin all day long and the page just refreshes.

                  Help

                  Comment


                  • #10
                    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                    Next, disable all plugins.

                    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                    define('DISABLE_HOOKS', true);

                    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      none of this worked

                      Originally posted by Steve Machol View Post
                      To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                      Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                      [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                      Next, disable all plugins.

                      Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                      define('DISABLE_HOOKS', true);

                      Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?

                      Comment


                      • #12
                        Then the problem is with how you set up those forums or an errant htaccess file. Assuming you have done everything suggested I don't know of any other possibilities.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X