Announcement

Collapse
No announcement yet.

3.7.1 - Fatal error: Allowed memory size of xx bytes exhausted

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3.7.1 - Fatal error: Allowed memory size of xx bytes exhausted

    I am also receiving the "memory exhausted" error in 3.7.1. In my case this appears to happen after a user clicks "post reply" or "post quick reply".

    My specific error is:

    Code:
    [B]Fatal error[/B]: Allowed memory size of 8388608 bytes exhausted (tried to allocate 
    19456 bytes) in [B]<path>/forum/includes/class_mail.php[/B] on line [B]835"[/B]
    I have very few plugins, but one that is in use sends instant email notifications to members who have chosen that notification method for forums or threads to which they have subscribed.

    Mark
    Last edited by conneva; Thu 29 May '08, 12:16pm. Reason: Reformatted using "code" blocks

  • #2
    Your PHP does not have enough memory allocated to it to complete this operation. Ask your host to increase the 'memory_limit' variable in php.ini to at least 32M.

    To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

    ini_set('memory_limit', 32 * 1024 * 1024);
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Steve,

      Why do you consider changing the memory_limit in config.php to be a temporary fix?

      Mark

      Comment


      • #4
        Because ideally you will follow the rest of my suggestion and contact your host to fix this.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          i dont know if this is the same issue....but i also had this memory exhaust during search ........i cam to this thread and i followed steve machol's advice above which solved my problem (memory exhausted)

          then i was checking few things today...it took my attention that the config.php i had was back from 3.5.0 ....never updated that one ....and i notice there are few changed regarding the memory...

          so by updating the config.php and uploading the new one...i dont get the memory exhaust any more


          i am not sure it is the same thing..but maybe it will help.

          rgds

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X