Announcement

Collapse
No announcement yet.

bogus error message editing CSS parameter

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bogus error message editing CSS parameter

    Hello,

    While trying to edit CSS parameters in the style manager, I am continuously getting the following :

    Required variables have gone missing and execution can not continue. Please try again.

    This error can sometimes occur as a result of Suhosin / Hardened PHP being installed on your server. If you know that you have Suhosin running and you have access to the PHP configuration, try increasing the value of the following variables:
    php_value suhosin.post.max_vars
    php_value suhosin.request.max_vars

    While I suppose that "required variables" going missing is possible, I am not running Suhosin on my site and I think the reference is simply bogus as you don't need Suhosin to get the error condition which makes an already frustrating situation cross over into PITA territory due to the stupidity of the statement.

    FYI, a busy or dirty network can apparently generate the same conditions.

  • #2
    Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Okay, thanks, I have enable the public phpinfo and my url is

      http://www.allaboutdatingsites.com

      As you will see, I am also running vbportal as well. The upgrade did not give any errors, btw. I posted a different but possibly related issue with the blog which is also installed on this site. The color picker went missing on the blog which is why I was trying change the CSS path, thinking that somehow it was incorrectly set. I think the blog doesn't like being in a subfolder but I don't see anyway to change a default path for it.

      thanks for the help. mikesz

      Comment


      • #4
        You are, in fact, running suhosin as shown by phpino:

        http://www.allaboutdatingsites.com/f...php?do=phpinfo

        vB generally does not lie about this.

        The most likely cause of this problem is the suhosin module in PHP. If so this can be fixed by editing the php.ini (requires root access to the server) or by via a .htaccess file with the following contents:

        php_flag suhosin.cookie.encrypt Off
        php_value suhosin.request.max_vars 2048
        php_value suhosin.post.max_vars 2048

        You can create your own .htaccess file and upload it to your main forum directory. It's a simple text file.

        If this doesn't work or you get an 'Internal Server Error' after doing this, then unfortunately this means that your host is not allowing this change. The only thing you can do now is to ask your host to make the necessary changes to suhosin.

        Here is a post that lists some of the recommended suhosin settings for compatibility with vB:

        http://www.vbulletin.com/forum/showt...82#post1329782
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Hello Steve,

          I apologize profusely. My server has been upgraded and I was never notified. In fact I thought/was running php 4 last time I checked it. I have only just moved to this server within the month and had concerns about them running php4 never guessing that my server had been upgraded. I should have checked that myself. Sorry for the confusion.v

          Thanks very much for the quick response.

          kindest regards, mikesz

          Comment


          • #6
            Hosts are sneaky sometimes.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              HA! LOL! I submitted a ticket with a request to modify the suhosin and they recompiled and removed it. Problem gone! Go figure...

              Thanks for the help.

              regards, mikesz

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X