Announcement

Collapse
No announcement yet.

Search not Working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Search not Working

    SInce I upgraded to 3.7 the serach function is not working.

    I search for terms such as "privacy" and "curtain" (words that exist in postings) but I get no results.

    Can someone suggest a fix?

  • #2
    Let's start at the beginning.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Tried it all and the problem still exists.

      The site is a "Westfalia" site with the word Westfalia mentioned hundreds of times.

      When I search for Westfalia, I get 6 results.

      Comment


      • #4
        Hmmm...I don't see how that is possible is you have search enabled and no modifications.

        What is the URL to you forums? And what are the results of Suspect Files?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I have a feeling that the

          define('DISABLE_HOOKS', true);

          didn't work since in suspect files it lists my mods.

          Comment


          • #6
            The url is http://www.westfalia.org/community/

            Comment


            • #7
              You still have at least one add-on installed - Arcade. Please try those instructions again.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                It seems that a few are still installed.

                Why wouldn't the DISABLE_HOOKS work?

                I added it to the config file n the includes folder.

                Comment


                • #9
                  Maybe you added it wrong. You also need to remove the iles for your add-ons from the 'includes/xml' directory.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    I updated to 3.7.1 and then I re-tried all of the above and my search still does not seem to work properly.

                    Isn't there some way to rebuild the search indexes?

                    Comment


                    • #11
                      Admin CP -> Maintenance -> Update Counters -> Rebuild Search Index
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        That did the trick.

                        The search is now working properly.

                        Thanks!

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X