Announcement

Collapse
No announcement yet.

var coloroptions = new Array() EMPTY!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • var coloroptions = new Array() EMPTY!

    Upgraded to 3.7 from 3.6.10, and our forum message editor no longer displays font color dropdown. I reverted headinclude. No dice. When I look at the source code, I see that coloroptions is the only array NOT being populated:

    var fontoptions = new Array("Arial", "Arial Black", "Arial Narrow", "Book Antiqua", "Century Gothic", "Comic Sans MS", "Courier New", "Fixedsys", "Franklin Gothic Medium", "Garamond", "Georgia", "Impact", "Lucida Console", "Lucida Sans Unicode", "Microsoft Sans Serif", "Palatino Linotype", "System", "Tahoma", "Times New Roman", "Trebuchet MS", "Verdana");
    var sizeoptions = new Array(1, 2, 3, 4, 5, 6, 7);
    var coloroptions = new Array();
    var smilieoptions = {
    'Generic Smilies' : {
    '94' : new Array('images/smilies/holysheep.gif', ':holysheep:', 'Holysheep'),
    '31' : new Array('images/smilies/001_cool.gif', ':001_cool:', '001 Cool'),
    '62' : new Array('images/smilies/rotfl2.gif', ':rotfl2:', 'Rotfl2'),
    '115' : new Array('images/smilies/yeahthat.gif', ':yeahthat:', 'Yeahthat'),
    '51' : new Array('images/smilies/happybday.gif', ':happybday:', 'Happybday'),
    '83' : new Array('images/smilies/biglove.gif', ':biglove:', 'Biglove'),
    '104' : new Array('images/smilies/neener.gif', ':neener:', 'Neener'),
    '40' : new Array('images/smilies/censored.gif', ':censored:', 'Censored'),
    '72' : new Array('images/smilies/whistling.gif', ':whistling:', 'Whistling'),
    '93' : new Array('images/smilies/giggle.gif', ':giggle:', 'Giggle'),
    '61' : new Array('images/smilies/rolleye11.gif', ':rolleye11:', 'Rolleye11'),
    '114' : new Array('images/smilies/waiting.gif', ':waiting:', 'Waiting'),
    '50' : new Array('images/smilies/grouphug.gif', ':grouphug:', 'Grouphug'),
    '82' : new Array('images/smilies/bellyemoticon.gif', ':bellyemoticon:', 'Bellyemoticon'),
    '103' : new Array('images/smilies/nana2.gif', ':nana2:', 'Nana2'),
    '39' : new Array('images/smilies/blushing.gif', ':blushing:', 'Blushing'),
    '71' : new Array('images/smilies/tongue_smilie.gif', ':tongue_smilie:', 'Tongue Smilie'),
    '92' : new Array('images/smilies/gaah.gif', ':gaah:', 'Gaah'),
    '60' : new Array('images/smilies/oops.gif', 'ops:', 'Oops'),
    '113' : new Array('images/smilies/thankyou.gif', ':thankyou:', 'Thankyou'),
    '49' : new Array('images/smilies/frown.gif', ':frown:', 'Frown'),
    '81' : new Array('images/smilies/banghead.gif', ':banghead:', 'Banghead'),
    '102' : new Array('images/smilies/nana.gif', ':nana:', 'Nana'),
    '38' : new Array('images/smilies/biggrin.gif', ':biggrin:', 'Biggrin'),
    '70' : new Array('images/smilies/tongue.gif', ':tongue:', 'Tongue'),
    '91' : new Array('images/smilies/furious.gif', ':furious:', 'Furious'),
    '112' : new Array('images/smilies/spit.gif', ':spit:', 'Spit'),
    '48' : new Array('images/smilies/drool5.gif', ':drool5:', 'Drool5'),
    '80' : new Array('images/smilies/badputer.gif', ':badputer:', 'Badputer'),
    '101' : new Array('images/smilies/lol3.gif', ':lol3:', 'Lol3'),
    '37' : new Array('images/smilies/ack2.gif', ':ack2:', 'Ack2'),
    '69' : new Array('images/smilies/thumbup1.gif', ':thumbup1:', 'Thumbup1'),
    '58' : new Array('images/smilies/o10.gif', '10:', 'O10'),
    '90' : new Array('images/smilies/dumbputer.gif', ':dumbputer:', 'Dumbputer'),
    '111' : new Array('images/smilies/smilie_woll_038.gif', ':smilie_woll_038:', 'Smilie Woll 038'),
    '47' : new Array('images/smilies/devil2.gif', ':devil2:', 'Devil2'),
    '79' : new Array('images/smilies/angry27.gif', ':angry27:', 'Angry27'),
    '100' : new Array('images/smilies/lalala.gif', ':lalala:', 'Lalala'),
    '36' : new Array('images/smilies/1eye.gif', ':1eye:', '1eye'),
    '68' : new Array('images/smilies/thumbdown.gif', ':thumbdown:', 'Thumbdown'),
    '57' : new Array('images/smilies/no.gif', ':no:', 'No'),
    '89' : new Array('images/smilies/duh.gif', ':duh:', 'Duh'),
    '110' : new Array('images/smilies/signs136.gif', ':signs136:', 'Signs136'),
    '46' : new Array('images/smilies/cursing.gif', ':cursing:', 'Cursing'),
    '78' : new Array('images/smilies/aloofandbored10.gif', ':aloofandbored10:', 'Aloofandbored10'),
    'more' : 'Show all Smilies'
    } };

    (Yeah, we like our smilies.)

    Any other ideas? I've tried the options given in the troubleshooting section, but no luck. THANKS!!!!

  • #2
    I have the same issue with my forum.

    Comment


    • #3
      Please make sure to upload the 3.7.0 clientscript files. They have changed since 3.6.X.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API

      Comment


      • #4
        It was the headinclude template. for some reason I hadn't reverted that one, it is good now.

        Comment


        • #5
          I re-uploaded the clientscript folder just to be sure (I know I uploaded it as part of the upgrade), but still no luck with the darn coloroptions. Headerinclude is reverted. Any other ideas?

          Thanks!!!

          Comment


          • #6
            OK, I've tried all suggestions, still no luck! It's driving me insane!

            I do have a custom stylesheet...I read about a bug that the headinclude freaks out on the link tags, so is this my issue?

            At a loss, and wasting too much time. Thanks for your help!

            Comment


            • #7
              DUH! I figured it out, finally. I simply reverted the editor_clientscript template. No, it wasn't altered in any way that I could see, but something happened that prevented the font colors from appearing.

              I guess it's actually true, when in doubt, revert.

              Thanks for the input!!!

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X