Announcement

Collapse
No announcement yet.

Charset problem: à/è/ì/ò/ù = �

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Charset problem: à/è/ì/ò/ù = �

    Hello, recently I've transferred my Forum to another hosting provider.
    Now I've a problem with charset (or collation).
    I'm italian (sorry for my english) and I need some characters with accents.

    I've imported all vB tables into phpMyAdmin with "utf8_general_ci" collation and I use a "ISO-8859-1" language charset on my Forum.
    Now, when I post, I see the normal characters, but all my users told me that see wrong characters.

    Then I've changed the vB language charset to "UTF-8", as recommended by You.
    It seems that new posts are correct. But now all the old posts that contain accents have a symbol like this: <?>

    I've checked my database and (fortunately) I have ascertained that all the characters are normal.

    Is there a way to replace <?> with the normal accents?

    I've read this thread ( http://www.vbulletin.com/forum/showthread.php?t=259250 ) but it hasn't been me useful.

    You can see my forums here: http://www.thecyberplanet.it/forum

  • #2
    The most common problem for this is caused by blank character stripper; you'd need to empty its content to correct only the new posts made AFTER the edit. Any posts made prior to the time you change the setting have already been broken up, so they cannot be fixed unless you manually go back and edit them. Occationally, we do see problem with the prevent shout and wrapping, but they're not as common... similar with the blank character stripper one; if it is already broken, there is no fix, you'd have to re-edit them yourself. But it will correct future postings.
    Best Regards,
    Andy Huang

    Comment


    • #3
      When you backup your database try to use with some PHP script. Something like mysqldumper with encoding utf8. When you restore try to use bigdump. Charset is the same with backup.
      Vui Ve Club - www.vuiveclub.net

      Comment


      • #4
        Originally posted by Andy Huang View Post
        The most common problem for this is caused by blank character stripper; you'd need to empty its content to correct only the new posts made AFTER the edit. Any posts made prior to the time you change the setting have already been broken up, so they cannot be fixed unless you manually go back and edit them. Occationally, we do see problem with the prevent shout and wrapping, but they're not as common... similar with the blank character stripper one; if it is already broken, there is no fix, you'd have to re-edit them yourself. But it will correct future postings.
        My forum is ruined! It's impossible for me to edit 20.000 posts.

        Originally posted by thanhdat View Post
        When you backup your database try to use with some PHP script. Something like mysqldumper with encoding utf8. When you restore try to use bigdump. Charset is the same with backup.
        Mmh... could you be more precise? Thanks.

        Comment


        • #5
          Try to set UTF-8 in your "Language and Phrases" --> "Language Manager" --> "HTML Character Set".

          Worked for me: you're not going to see fixed the threads that are already in the DB, but the new ones are correct.

          Hope this helps.

          Comment


          • #6
            The language charset is already on UTF-8.

            Comment

            Related Topics

            Collapse

            Working...
            X