Announcement

Collapse
No announcement yet.

Upload Pictures in Albums

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upload Pictures in Albums

    Newbie alert. Just upgraded from 3.6 to 3.7 and trying to get Albums working. I currently have it setup to store in the database (will move to filesystem once it's working). The problem I'm having is that the picture appears to upload just fine (no error message), but then it's just a broken link.

    Here is the link:
    http://vfrworld.com/forums/album.php?albumid=2

    Attached is a screenshot.

    I assume this is a simple setup that I haven't been able to find.

    Click image for larger version

Name:	albumprob.jpg
Views:	1
Size:	10.4 KB
ID:	3707054

  • #2
    What happens when you try the Upload diagnostics?

    Admin CP -> Maintenance -> Diagnostics -> Upload

    Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Perhaps the same problem I had?

      http://www.vbulletin.com/forum/showt...ighlight=album

      Problem was resolved by eliminating non-printing characters from config.php file. Still trying to understand how they got there.

      Mark

      Comment


      • #4
        The Upload Diagnostics were successful.

        I have enabled PHPinfo:
        http://vfrworld.com/forums/misc.php?do=phpinfo

        What's the trick to looking for non-printing characters in config.php? I use VI and don't see any.

        Thanks for the quick responses.

        Comment


        • #5
          You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main hosting directory and chmod it to 777.
          Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

          /home/michael/tmp

          Also the php.ini setting for 'upload_tmp_dir' is: /usr/home/tmp

          You (as root) or your host will need to check to make sure that directory exists and that it is chmod'd to 1777.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Well, I tried everything you suggested, with the exception of the upload_tmp_dir in php.ini. My web host is generally reluctant to make these kinds of changes, and I don't blame them. Assuming this is what is causing my problem (it may not be), I might suggest you find a different way to handle uploads in a future release. It seems odd that users can upload attachments just fine, but you utilize a different methodology for the new Album feature. But, I'm sure there's probably a good technical reason.

            Please let me know if you have any other suggestions to try, otherwise I guess I will just turn off the album feature.

            Comment


            • #7
              You will have to contact your host. Sorry.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X