Announcement

Collapse
No announcement yet.

White Hell: The Failed Upgrade from 3.6.10 to 3.7.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • White Hell: The Failed Upgrade from 3.6.10 to 3.7.0

    I posted this in the wrong forum thread so I decided to move it here to get some better attention.

    I am new to VB and I have a problem when I upgraded from 3.6.10 to 3.7.0. Zachary has been trying to asynchronously help me but since there is a 10 hour time difference between us I was hoping to speed things up a bit.

    I have a vB forum with a blog and photopost gallery installed. Everything was going well until the upgrade. As far as I could tell the upgrade to 3.7.0 went smoothly even though it was a long process going from all the beta versions and release candidates to reach the final stage. During the final stage I got to the login screen but after that the page was white. Nothing on the forum worked anymore. I tried using tools.php and everything there seems to work - no errors. I even transferred the old config.php info over to the new config.php

    No changes have been made to my server (httpd or mysql or php). These are all the latest versions.

    I have tried multiple uploads and re-upgrading and have the same problem again and again. I myself, have been considering doing a clean re-install as discussed here so I wonder if the process described here would actually work:
    1.) backup the current database (done)
    2.) do a clean install (essentially deleting all data?)
    3.) reload the data from the backup database.

    I need a solution since I put about 2 weeks of work into building the site to make it a community and I hate to do all that work again and try to ask the people to re-register.

    Zachary seems to be doing the best he can in spite of the time differences so I ask for the gurus here, who might be in a European time zone to see if anyone has any ideas of what actions I can take (details please) of what I can do. I don't want to lose anything. I don't see any database errors but for some reason unknown the whole forum is white - any page shows up white EXCEPT the upgrade screens, installation screens, and the login for the admincp.

    It must be a simple fix but if it is, I need to know how I can go about diagnosing it. I made a backup of the database and I can e-mail it to someone if the problem can be traced back to that but somehow I think that it is not the problem. At this point I am almost ready to delete everything and start over from scratch. Last resort so I turn to you gurus out there to help a slightly experienced newbie

    Thanks,
    -Z (a.k.a. Ed)

  • #2
    re-upload and overwrite all of your forum folders including admincp

    Comment


    • #3
      well every time after an upgrade when i get to a blank page i have to del the install.php file...after the deleting it, it works fine and i log on my admin cp!

      Comment


      • #4
        I appreciate the actions to take but I have done it -several times in fact. I thought at first it might be a ascii upload problem so then I uploaded the files from the tarball within my Linux server and copied the files over that way rather than using the ftp program from my home computer. Still no help. I admit if I knew more about php I could diagnose the problem better but I am clueless what to look for.

        I also tried the different actions in the troubleshooting part about white pages and it didn't help.

        Thank you for suggesting these things

        Comment


        • #5
          Link please
          vBProjects - Professional vBulletin Services and Solutions
          vBSpring - Premium vBulletin Add-ons

          Comment


          • #6
            Here is the link to the forum installation:
            Http://www.ldsn.org/fma/forum


            The current error I get in firefox is white space and in internet exploder I get an error 500. Not sure what is gong on or NOT going on.

            I will be back in about an hour. Need to do some errands.

            Comment


            • #7
              I think you need an installation support with FTP access so anyone can look at your file and see what's problem. For example, is there index.php in this directory or not and many other problems that can cause such problems

              Did you try to start upgrade form the first step?
              vBProjects - Professional vBulletin Services and Solutions
              vBSpring - Premium vBulletin Add-ons

              Comment


              • #8
                Thanks for the support. I have tried all the instructions in the link. No luck. I have a ticket in support and Zachary has promised to help out today as well. Let's see. I will post the solution when I get it.

                Comment


                • #9
                  Finally and error...

                  After playing around trying to fix it I have this error in the httpd error log:
                  [Sat May 03 21:57:40 2008] [error] [client SNIP] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required '/SNIP/forum/includes/vbgallery/style_fetch.php' (include_path='.:/usr/share/pear:/usr/share/php') in /SNIP/forum/global.php(243) : eval()'d code on line 8, referer: http://SNIP/forum/admincp/

                  Any ideas? It seems it is looking for files that don't exist anymore. At least not in 3.7.0.

                  Comment


                  • #10
                    This error is from a plugin you've installed. You need to disable each of your plugins then turn one at a time to see which one is causing this.

                    If you cannot log into the Admin CP then to disable the plugin system, edit config.php and add this line right under <?php

                    define('DISABLE_HOOKS', true);

                    This will disable all hooks and allow you to log in properly with no hooks running.

                    http://www.vbulletin.com/docs/html/disable_plugins
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Problem solved. Thanks!

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X