Announcement

Collapse
No announcement yet.

Blank pages related to Forbidden Messages?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Blank pages related to Forbidden Messages?

    I upgraded to 3.7 and have been getting some forbidden messages, so I added in the little htaccess rule that I found in the mod_security section of this site.

    However, another weird error that is happening is random blank white pages. It doesn't seem to be any particular one page, it is just randomly when you're clicking through on the site, a page will show up totally blank. If you hit the back button, then retry, it'll usually come up after a time or two or three.

    Are these two things somehow related or totally different issues? Any idea what would be causing the random blank white pages?

    I don't have any major modifications installed except ibproarcade and GAB ads. So, I don't think it's one of my modifications. I just thought I'd see if you guys have any ideas.

    Thank you!

  • #2
    Here is a copy of another here that some members have gotten. Is this memory related?
    Attached Files

    Comment


    • #3
      Still getting them.

      Comment


      • #4
        These are the ones we're getting:


        Warning: main([path]/includes/class_hook.php) [function.main]: failed to open stream: Too many open files in system in [path]/includes/init.php on line 265

        Fatal error: main() [function.require]: Failed opening required '/home/military/public_html/forum/includes/class_hook.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/military/public_html/forum/includes/init.php on line 265

        -------------------------------------------

        Warning: Unknown([path]/gallery/thumbnails.php): failed to open stream: Too many open files in system in [path]/search.php(3736) : eval()'d code on line 9

        Fatal error: (null)() [function.require]: Failed opening required '/home/military/public_html/forum/gallery/thumbnails.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/military/public_html/forum/search.php(3736) : eval()'d code on line 9

        -----------------------------------------------------------

        Forbidden
        You don't have permission to access /forum/search.php on this server.

        Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


        Apache/1.3.39 Server at militarysos.com Port 80

        ------------------------------------------------------------

        edited to add: could these be related to having APC or xcache recently installed? I asked them to install it but upon having other major issues with it (my two separate sites were having information, posts and members mixed between the two- it was really strange) I had them uninstall them. I'm wondering if these could be lingering effects from that.
        Last edited by BrandiDup; Thu 1 May '08, 3:54am.

        Comment


        • #5
          You've got a bunch of things going on. At least one of them is from an add-on.

          To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

          Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

          [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

          Next, disable all plugins.

          Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

          define('DISABLE_HOOKS', true);

          Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X