Announcement

Collapse
No announcement yet.

There are errors in the settings on this page?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • There are errors in the settings on this page?

    I just upgraded to 3.7.0 today. I'm in my vbulletin options - edit settings. I chage the email address and go to save the settings and now I get a pop up window stating "There are errors in the settings on this page. Are you sure you want to save the settings?" I have not changed a thing since updating from 3.6.10. What could this be?

    How do I tell where the errors are?

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I went through each option separetly and found my avatar per page was changed from 1 to 0. Hmmmm

      Oh well now I can save my settings with out the error message.

      Comment


      • #4
        WOW Steve your fast!!!!!!!!!

        Thanks anyways.

        Comment


        • #5
          Glad you figured it out.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I had this happen too, was the same exact thing too.

            There was a error caption, saying that the value must be at least 1. Perhaps the pop up error message should have the same text
            http://www.voogru.com
            http://forums.voogru.com

            Comment


            • #7
              This one had me going too!

              If you work in options with -- Show all Settings -- then you have no idea why you are being hit with "There are errors in the settings on this page. Are you sure you want to save the settings?"

              One by one, I went to each setting group and clicked the save button. I finally found it on "User Profile Options" and there was a "0" instead of a "5" in "Maximum Visitors to Show on Profile Page".

              The actual error message was: Error:
              You did not enter a valid value for this setting.

              If you work in -- Show all Settings -- and you get this error, do a Control "F" and search for "Error" and you find your point of didaster.

              vBulletin is getting HUGE over time, but we'll dig in and learn.

              Comment


              • #8
                Thanks guys, this thread saved me some head scratching - same thing, avatars per page set to 0 on upgrade

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X