Announcement

Collapse
No announcement yet.

Error: Security token was missing or mismatched

Collapse
This topic is closed.
X
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    If you have Blog 1.0.5 installed, please see this bug report an fix:

    http://www.vbulletin.com/forum/proje...?issueid=25301

    Leave a comment:


  • Steve Machol
    replied
    If this problem is only happening to some people and cannot be reproduced, the probable cause is their browser cache. Have these users either try a different browser or clear their browser cache.

    Otherwise an ISP cache may also be to blame.

    Leave a comment:


  • Steve Machol
    replied
    Some people have reported this problem when uploading very large file attachments.

    In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf (or my.ini for Windows systems)

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Note: Do NOT use MB, just M for the megabytes setting.

    You may also need to increase the memory_limit, max_execution_time and max_input_time variables in php.ini.

    Also you might want to take a look at this for other settings that affect file uploads:

    http://www.vbulletin.com/forum/showp...0&postcount=12
    http://www.vbulletin.com/forum/showt...319#post748319

    Leave a comment:


  • Steve Machol
    replied
    Also see these instructions over at vbulletin.org for implementing this into any add-ons: Implementing CSRF Protection in modifications

    Leave a comment:


  • Steve Machol
    started a topic Error: Security token was missing or mismatched

    Error: Security token was missing or mismatched

    If you receive this error, please follow these steps.

    One possibility is that you did not upload all the 3.7.0 files when you upgraded. Please reupload all the 3.7.0 non-image files. Then run install/finalupgrade.php. Make sure that you see versions 3.7.0 in the upper right hand corner of the page.

    If you still have this problem after that, then try this. Create a new style and choose no parent style. This will force it to use the default templates. Then change to this style and view your forums with it. Do you have the same problem? If not, then this is a problem with your custom templates. You will need to revert your templates and redo your changes.

    If you do, empty your browser cache, close all browser windows and try again.

    If this is still not resolved, then reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins, except the official Blog and Project Tools ones from vB. Also make sure that you are running the latest version for those add-ons if you have them. Now empty your browser cache and try again.

    NOTE: If you had any add-ons installed, these will may need to be updated for 3.7.0. You will need to contact the authors of your add-ons about this. See post #2.
    Last edited by Zachery; Tue 29th Apr '08, 7:46am.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X