Announcement

Collapse
No announcement yet.

Image verification not showing image

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Image verification not showing image

    I turned on image verification but no image appears when a user is trying to register.

    I found the TTF fonts that are included with vBulletin and I entered their font names in the list of fonts to use for image verification, however still there is no image.

    By "no image" I mean no text, no background, nothing.

    I first saw this problem in 3.7 beta 5. I upgraded to 3.7 rc2 and the problem has not gone away.

    I have selected GD graphics and my PHP info says that I have GD.

    Anybody know what could be going wrong?

    Thanks.
    Last edited by James_Hotmovies; Thu 10 Apr '08, 5:30am.

  • #2
    This is caused by Freetype 2 support not being compiled into PHP and requires PHP to be recompiled. Most likely the original PHP configure string contained --with-freetype but this usually only enables support for Freetype version 1, which does not support True Type fonts.

    To enable Freetype 2 support (assuming that the server has the Freetype 2 libraries installed), this part of the configure string neeeds to be removed and replaced with (normally) --with-freetype-dir=/usr

    To find out if a Linux server has Freetype 2 support, run locate freetype2 at the command line and look for some results, usually in /usr/include/freetype2.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      FYI, I also tried putting some pfa/afm Type1 fonts in the regimage/fonts directory and that didn't help.

      Comment


      • #4
        Originally posted by James_Hotmovies View Post
        FYI, I also tried putting some pfa/afm Type1 fonts in the regimage/fonts directory and that didn't help.
        vBulletin only uses Truetype fonts as far as I am aware.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment


        • #5
          Freetype2 is present

          Hello,

          I checked and it turns out that freetype2 is present on our server. We have freetype-2.2.1-19.el5.

          Any ideas about what else could be going wrong?

          Thanks.

          Comment


          • #6
            Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

            Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              The URL is http://xrated.com/forum

              I'll have to get permission to enable phpinfo...

              Comment


              • #8
                Sorry, the administrator has disabled PHP Info display.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Hello everybody.

                  After upgrading from 3.6.10 to 3.7 the image verification stoped working here. See image in attach.

                  After reading this thread this is what I had to do:

                  1. Download Freetype from the link below. I used the latest version at the time (2.3.5):

                  http://download.savannah.gnu.org/releases/freetype/

                  2. Unpack and do a simple compilation/installation with ./configure && make && make install

                  3. Recompile PHP for freetype support. Contrary to what is written above, the default installation is made at /usr/local and not at /usr. So you need to add the following parameter to your PHP configure line:

                  --with-freetype-dir=/usr/local

                  You can always see what is the current configure line running phpinfo as described above.

                  4. Then simply compile PHP with your configure line followed by make and make install.

                  5. Done. You can configure your image settings on the adminCP under the new option "Human Verification Manager" located under "vBulletin Options" on the left panel.

                  Cheers,
                  Gabriel.
                  Attached Files

                  Comment


                  • #10
                    I have had the same problem.

                    I have reinstalled freetype 2.2.1-19.
                    I have installed freetype-devel.
                    I have recompiled PHP --with-freetype-dir=/usr, make, make install.

                    GD still does not work. (I get a blank white box.) Any ideas?

                    Comment


                    • #11
                      Please start your own thread with all the relevant info including the info asked for in this thread.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Try either reverting templates or create new style and register using the newly made unmodified style.

                        Comment


                        • #13
                          './configure' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-magic-quotes' '--enable-sockets' '--prefix=/usr/local' '--with-apxs=/usr/local/apache/bin/apxs' '--with-freetype-dir=/usr' '--with-gd' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libxml-dir=/opt/xml2/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-png-dir=/usr' '--with-ttf' '--with-xpm-dir=/usr/X11R6' '--with-zlib' '--with-zlib-dir=/usr'
                          gd

                          GD Support enabled GD Version bundled (2.0.28 compatible) FreeType Support enabled FreeType Linkage with freetype GIF Read Support enabled GIF Create Support enabled JPG Support enabled PNG Support enabled WBMP Support enabled XBM Support enabled

                          And yet none of the human verification options work.
                          Upgraded from 3.6.8 to 3.7

                          Comment


                          • #14
                            You need FreeType2. And for future reference, please start you own thread.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X