Announcement

Collapse
No announcement yet.

Database Prob

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database Prob

    I uninstalled an arcade off my forum.

    Only problem is its throwing up adatabase error when i try to access the forum and I can't log into the admincp either.

    Is there a safe mode I can access to get in?
    Website - http://www.gamerskingdom.net/Buttons/gkf10.png

  • #2
    If the uninstall of the arcade didn't properly uninstall please ask for support on the unofficial addon from the author of the addon.

    You can try to reset to default:

    -----------------


    First, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Now check again.

    Do you still have the same problem?

    Comment


    • #3
      All I needed was the part about disabling the plugins. I can now acces the admincp.

      Reset the styles until i can fix the main prob anyhow.

      Thanks.
      Website - http://www.gamerskingdom.net/Buttons/gkf10.png

      Comment


      • #4
        You can create a new style and set parent to none, and use that style. You don't have to 'throw away' the old style.

        Comment


        • #5
          I haven't reset the style, found the plugin that was calling for a table in the database that no longer existed. Took me a while to find it.

          What i didn't understand was the plugin was still runnning even thogh nothing on the page was looking for it..

          Also another question, How do I delete something off my ftp when it keeps coming up as being access denied??
          Website - http://www.gamerskingdom.net/Buttons/gkf10.png

          Comment


          • #6
            Depends, don't delete any vBulletin files. If you get permission denied then try to chmod 755 the file and then delete it. Or ask the host to reset the file using chown and chmod.

            Comment


            • #7
              Ok thanks for your help.

              Might want to add the part about turning plugin off in your config file to an faq somewhere. Or make it an option that you can turn on and off.
              Website - http://www.gamerskingdom.net/Buttons/gkf10.png

              Comment


              • #8
                You can go to the products and plugins managers and select to enable/disable /export/uninstall them.

                And the global hook system can be turned off from the admincp > vb options > vb options > hook system.

                Comment


                • #9
                  Originally posted by loonytune15 View Post
                  Ok thanks for your help.

                  Might want to add the part about turning plugin off in your config file to an faq somewhere. Or make it an option that you can turn on and off.
                  http://www.vbulletin.com/docs/html/v...in_hook_system

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X