Announcement

Collapse
No announcement yet.

Thumbnail creation failed due to your image library not having support for this image

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Thumbnail creation failed due to your image library not having support for this image

    I am getting this error when trying to upload non image files such as doc format.

    I checked my settings for attachments and thumbnails are turned off for the non image formats.

  • #2
    Hmmm..I don't see how that can be. Have you installed any add-ons?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Yes but I do not see anything with a hook related to attachments besides the following:
      VBSeo
      Blog Attachments blog_entry_attachmentbit


      I tried just attaching my .doc file to this post at Vbulletin and recieved this error.

      The Dimension limits for this filetype are 0 x 0. We were unable to resize your file so you will need to do so manually and upload it again. Your file is currently x .

      Update:
      After some testing it appears to be kicking out the wrong error messages.
      The proper error message should have been one related to being over the limit on file size. I believe it is attempting to resize the attachment even though it is not an image format.

      Comment


      • #4
        Note: We cannot provide official support to forums running non-vB code.

        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all plugins.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          All files verified by diagnostics (VB version 3.7 B3)

          I disabled all plugins. The config file setting did not work so I disabled them in Admincp -> VBulletin Settings -> Plugin/Hook System

          Attachment settings
          doc50000 YesNoNo

          I used two files for this test

          25k file size Word Document
          300k file size Word Document

          25k uploads without a problem

          300k document kicks out the error:
          Thumbnail creation failed due to your image library not having support for this image type.

          I can duplicate the error here on vbulletin.com using the same test files except the error returned is:

          The Dimension limits for this filetype are 0 x 0. We were unable to resize your file so you will need to do so manually and upload it again. Your file is currently x
          Last edited by Aakek; Wed 9 Jan '08, 10:48am. Reason: Removing attachment

          Comment


          • #6
            What are all of your settings for Word docs?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Extension: doc
              File size: 50,000
              Max Width: 0
              Max Height: 0
              Mime Type: Content-type: application/msword
              Thumbnail: No
              Open in new window: No
              Enabled: yes

              Comment


              • #8
                Honestly then I dont see how the default vB would be trying to create a thumbnail. In fact, I cannot duplicate this problem with an unmodified 3.7.0 Beta 3 forum. I'm afraid the next step is to remove all your modifications to see if you have the same problem.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Well for now I can increase the file size then try to reconstruct on my test forum starting with a clean install.

                  I will update this thread if I find out any additional information since it can be duplicated on this website as well (with a different error message).

                  Comment


                  • #10
                    I had this same problem too - doc and rtf both.
                    I increased the allowed file size to 5000 and now OK.

                    Comment


                    • #11
                      I have this problem on an imported account (from an SMF forum) but not on the fresh admin account I created when I installed the forum. Any thoughts on this please?

                      I can upload an avatar with my main admin account but not with an old imported account.

                      Comment


                      • #12
                        Fixed it now.

                        Comment


                        • #13
                          I have the same problem, obviously an error in VB, not with a mod or add-on because it started happening with the 3.7 upgrade. I will simply up the Word/.doc file size and fix it that way until the code itself is fixed.

                          Comment


                          • #14
                            I'm Having the same error in Pic, but it was Working fine till I moved to Another host and then this problem Accrued to me...

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X