Announcement

Collapse
No announcement yet.

Custom icons per forum - where?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Anybody has tried? Am I the only member who wants custom icons?

    Comment


    • #17
      Originally posted by soundbarrierpro View Post
      Anybody has tried? Am I the only member who wants custom icons?
      I got this to work fine. I added just one prefix to test. I used an image and it worked like a charm.

      Comment


      • #18
        Originally posted by soundbarrierpro View Post
        Anybody has tried? Am I the only member who wants custom icons?
        I am also looking for help on this matter, have tryed every thing stated here and still nothing.

        Comment


        • #19
          I hadn't realize it would be such a pain in the neck to make them work. I use this.

          http://www.vbulletin.org/forum/showt...=102025&page=9

          Go to page 8 and 9 to get instruction to make work. It's excellent and lets you change "ALL" of your forum/subforum status icons.

          Comment


          • #20
            OK I'm going to try and explain this a little more in depth than it already has been to help some folks out. I too didn't get anything specific enough to make this easily understood.

            Here is what you do to make this work. I'm going to explain what I did so others don't have to install unnecessary Mods to use a function that is built into Vb 3.7.

            First, create a folder in your /images/statusicon/ directory for your custom forum icons.
            I used the forum ID# for each custom forum icon set. To get the forum Id, just hover your mouse over which ever forum you intend to have custom icons and note the # at the end of the target link.
            Example highlighted in red: http://www.yoursite.com/forum/forumdisplay.php?f=15
            I did this because that is how it worked when I used a similar forum icon mod for SMF. You can name your folders whatever you want though.
            Below is an example of what the path should look like with the new folder added.
            images/statusicon/15/

            Now you can just rename your custom icons exactly like the default forum icon set and upload them to your custom directory.
            ie: forum_new.gif, forum_old.gif, forum_new_lock.gif, forum_old_lock.gif, etc...

            After you rename your custom icons exactly like the default set and have uploaded them to the folder you created, you can now go into that forums settings and add this to the Prefix for Forum Status Images dialog box. 15/

            Once you do that and hit save and your icon should now be showing on your forum.

            Just so you know you can alternatively create your icons and just leave them within the default statusicon directory. Doing it this way would mean you would just rename your custom icons like so.

            15_forum_new.gif, 15_forum_old.gif. etc..

            You would then only enter the prefix of
            15_ into the Prefix for Forum Status Images dialog box. I just prefer making folders as I'm used to it.


            Hope this clears it up a bit more.



            Comment


            • #21
              Thx that worked, but not on my forumhome
              When i go into the category i will see it but why not on the forumhome.
              I dont understand why u cant use a unc path to the image for a custom forum image.
              On vb.org were good hacks who did that for older versions than 3.7

              Comment


              • #22
                Originally posted by TheFirm View Post
                Thx that worked, but not on my forumhome
                When i go into the category i will see it but why not on the forumhome.
                I dont understand why u cant use a unc path to the image for a custom forum image.
                On vb.org were good hacks who did that for older versions than 3.7
                Can you post a screenshot? There is no reason why it shouldn't be showing up on forum home. Also, make sure you create the custom "_locked.gif" files or else when your logged out nothing will show up on your forum home. Dunno if that is what the problem is maybe?

                Comment


                • #23
                  Help doing this please?

                  This site has custom icons, in the forum title field.

                  http://tronixnews.com/forum/

                  How did they do that ?

                  Im sure thats not the post icons ( forum icons ) described in this thread.

                  Any help greatly appreicated.


                  Ozzy

                  Comment


                  • #24
                    I was going to switch to using this but not only is this system much harder to use, (having to state it per forum- should be able to state a pattern for all forums, i.e. using variables such as forum id etc. And the code should look to see if that image exists else show the default one. That's what the custom one I use does.

                    And we currently use png images for out status icons, so using this feature simply isn't possible. I would have been happy to overlook the first issue but the images just look awful in gif format so can't put up with going back to using them. If there was a global setting allowed for the filetype to use for status icons that would have easily sorted that issue lol.

                    Comment


                    • #25
                      Originally posted by consolegaming View Post
                      I was going to switch to using this but not only is this system much harder to use, (having to state it per forum- should be able to state a pattern for all forums, i.e. using variables such as forum id etc. And the code should look to see if that image exists else show the default one. That's what the custom one I use does.

                      And we currently use png images for out status icons, so using this feature simply isn't possible. I would have been happy to overlook the first issue but the images just look awful in gif format so can't put up with going back to using them. If there was a global setting allowed for the filetype to use for status icons that would have easily sorted that issue lol.
                      you can change the file format from gif to png in the templates section:

                      FORUMHOME Templates > forumhome_forumbit_level1_post

                      FORUMHOME Templates > forumhome_forumbit_level2_post

                      Comment


                      • #26
                        actually a better option for you would probably be to use this modification from vbulletin.org which makes the whole process a lot simpler: http://www.vbulletin.org/forum/showthread.php?t=102025

                        Comment


                        • #27
                          Originally posted by TimberFloorAu View Post
                          This site has custom icons, in the forum title field.

                          http://tronixnews.com/forum/

                          How did they do that ?

                          Im sure thats not the post icons ( forum icons ) described in this thread.

                          Any help greatly appreicated.


                          Ozzy
                          I'm using vB 384
                          Edit the "forumhome_forumbit_level2_post" template

                          Find and Replace:

                          <img src="$stylevar[imgdir_statusicon]/forum_$forum[statusicon].gif" alt="" border="0" id="forum_statusicon_$forum[forumid]" /></td>

                          with

                          <img src="$stylevar[imgdir_statusicon]/$forum[imageprefix]forum_$forum[statusicon].gif" alt="" border="0" id="forum_statusicon_$forum[forumid]" /></td>

                          *** You just added this "$forum[imageprefix]"
                          Last edited by obetyance; Tue 13 Apr '10, 8:27pm.
                          http://www.filairsoft.com

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X