Announcement

Collapse
No announcement yet.

How do u upgrade to vBulletin 3.7.0 beta2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do u upgrade to vBulletin 3.7.0 beta2

    Do we have to download that Impex or the entire product?

    Anybody know?

    I'm upgrading from 3.6.7

    thx

  • #2
    Don't install impex.

    Download the 3.7 files
    unpack it
    upload it to the server
    run upgrade.php
    and you're done.

    Comment


    • #3
      Originally posted by Floris View Post
      Don't install impex.

      Download the 3.7 files
      unpack it
      upload it to the server
      run upgrade.php
      and you're done.
      O thx,

      I was just about to do the Impex thing.

      Great timing there.

      Comment


      • #4
        Please read the announcement, it is very clear that you can't use impex on 3.7.
        It also says that you have to be experienced and know the way vb is being upgraded, and they don't recommend running it on your live site.

        I also wish to repeat: make a .sql dump backup of the database, and a backup of your 3.6 files. So you can revert back to it when the upgrade goes bad for you.

        Comment


        • #5
          Originally posted by Floris View Post
          Please read the announcement, it is very clear that you can't use impex on 3.7.
          It also says that you have to be experienced and know the way vb is being upgraded, and they don't recommend running it on your live site.

          I also wish to repeat: make a .sql dump backup of the database, and a backup of your 3.6 files. So you can revert back to it when the upgrade goes bad for you.
          Silly question maybe, but how does one actually make an .sql dump backup?

          Comment


          • #6
            http://www.vBulletin.com/go/backup
            http://www.vBulletin.com/go/restore

            I recommend to use SSH2/Shell access

            Comment


            • #7
              Originally posted by Floris View Post
              Excellent. Much obliged Sir.

              Comment


              • #8
                This is the message I get on my screen

                This script will update your vBulletin installation to version 3.6.8
                Press the 'Next Step' button to proceed.
                But I want to upgrade to 3.7.

                Can anybody tell me how to go about doing that?

                thx

                Comment


                • #9
                  press the NEXT STEP button to proceed (just like it says), then it will upgrade to 3.7

                  Comment


                  • #10
                    Originally posted by dodgeboard.com View Post
                    press the NEXT STEP button to proceed (just like it says), then it will upgrade to 3.7
                    thx

                    I would of never known that if u wouldn't of told me.

                    Appreciated.

                    Comment


                    • #11
                      Are you being serious?

                      Comment


                      • #12
                        Originally posted by dodgeboard.com View Post
                        Are you being serious?
                        Yes, dead serious.

                        I was upgrading from 3.6.7 and it prompted me telling me that it's upgrading to 3.6.8.

                        I mean I had no idea it would upgrade to 3.7.

                        Comment


                        • #13
                          All vb upgrades do that, if you are more than one version away from the install package- it does it in steps.

                          Comment


                          • #14
                            Yeah, the upgrade.php script auto detects what you have installed and what the latest version is, and upgrades you to that latest version, step by step. Sometimes this means it also requires you to go through the steps from versions that are in between.

                            This way you only have to upload the latest build, run upgrade.php .. and vB does the rest for you. You don't have to download/upload each incremented version one by one to upgrade.

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X