Announcement

Collapse
No announcement yet.

cry.. (The used table type doesn't support FULLTEXT indexes)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cry.. (The used table type doesn't support FULLTEXT indexes)

    im having a problem from step 1


    Database error in vBulletin 3.6.8:
    Invalid SQL:
    CREATE TABLE socialgroup (
    groupid INT unsigned NOT NULL auto_increment,
    name VARCHAR(255) NOT NULL DEFAULT '',
    description TEXT NOT NULL DEFAULT '',
    creatoruserid INT unsigned NOT NULL DEFAULT '0',
    dateline INT unsigned NOT NULL DEFAULT '0',
    members INT unsigned NOT NULL DEFAULT '0',
    picturecount INT unsigned NOT NULL DEFAULT '0',
    lastpost INT unsigned NOT NULL DEFAULT '0',
    lastposter VARCHAR(255) NOT NULL DEFAULT '',
    lastposterid INT UNSIGNED NOT NULL DEFAULT '0',
    lastgmid INT UNSIGNED NOT NULL DEFAULT '0',
    visible INT UNSIGNED NOT NULL DEFAULT '0',
    deleted INT UNSIGNED NOT NULL DEFAULT '0',
    moderation INT UNSIGNED NOT NULL DEFAULT '0',
    PRIMARY KEY (groupid),
    KEY creatoruserid (creatoruserid),
    KEY dateline (dateline),
    FULLTEXT KEY name (name, description)
    );
    MySQL Error : The used table type doesn't support FULLTEXT indexes
    Error Number : 1214

  • #2
    Seems like the same issue as the other one I just split over... except you're doing an upgrade instead of a fresh install. What MySQL server version are you guys using and what's your default table type?
    Best Regards,
    Andy Huang

    Comment


    • #3
      It appears that MySQL 5 on Windows servers are setting default table types to innodb instead of myisam, and as innodb doesn't support fulltext, it causes that problem... devvies are testing a fix for this already, but I don't know when it will be released. In the mean time, you can try this:
      Locate your my.ini (or my.cnf, not sure which one its called on your system) and find:
      Code:
      default-table-type=innodd
      replace with:
      Code:
      default-table-type=myisam
      then, restart mysql server and try again.

      You're upgrading, so DO NOT drop the database as I suggested in another post, or you will lose data.
      Best Regards,
      Andy Huang

      Comment


      • #4
        4.1.20 mysql
        4.3.6 php

        Comment


        • #5
          Originally posted by Andy Huang View Post
          It appears that MySQL 5 on Windows servers are setting default table types to innodb instead of myisam, and as innodb doesn't support fulltext, it causes that problem... devvies are testing a fix for this already, but I don't know when it will be released. In the mean time, you can try this:
          Locate your my.ini (or my.cnf, not sure which one its called on your system) and find:
          Code:
          default-table-type=innodd
          replace with:
          Code:
          default-table-type=myisam
          then, restart mysql server and try again.

          You're upgrading, so DO NOT drop the database as I suggested in another post, or you will lose data.
          dont have access to reseting the sql server..etc


          i guess i will just copy the 3.6.7 files back over and wait it out

          Comment


          • #6
            Hm... please check your my.cnf / my.ini for the setting I mentioned above, and give that a try... It should work as it did for dkon26.

            Edit:
            ah, okay... devvies are testing a new build which should work w/o having to restart mysql and do any edits... I'll make a mental note to post back when that is released


            Blargh, for multi tabbing and slow typing :/
            Best Regards,
            Andy Huang

            Comment


            • #7
              Originally posted by Andy Huang View Post
              Hm... please check your my.cnf / my.ini for the setting I mentioned above, and give that a try... It should work as it did for dkon26.

              Edit:
              ah, okay


              Blargh, for multi tabbing and slow typing :/

              im using a paid shared host and cant do any of that stuff

              Comment


              • #8
                Thanks - works for me (testing using WAMP for windows).

                Comment


                • #9
                  Originally posted by Pottsy View Post
                  Thanks - works for me (testing using WAMP for windows).
                  congrats i cant wait to use 3.7

                  Comment


                  • #10
                    Redownload your files as this should be fixed now.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #11
                      thanks Wayne.. doing that now

                      Comment


                      • #12
                        Thanks Wayne!
                        It works now!!
                        You guys are the best

                        Comment


                        • #13
                          Yay, congrats and welcome to 3.7 Beta
                          Best Regards,
                          Andy Huang

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X