No announcement yet.

When I try save changes in forum template I received error:

  • Filter
  • Time
  • Show
Clear All
new posts

  • When I try save changes in forum template I received error:

    When I try save changes in forum template I received error:

    Warning: implode() [function.implode]: Invalid arguments passed in /admincp/css.php on line 103
    Fatal error: Invalid styleid specified in /includes/adminfunctions_template.php on line 327
    #0 vb_error_handler(256, Invalid styleid specified, /virtual/pl/xxxx/forum/includes/adminfunctions_template.php, 327, Array ([styleid] => 0,[doreturn] => 1,[parentids] => ,[vbulletin] => vB_Registry Object ([datastore] => vB_Datastore Object ([defaultitems] => Array ([0] => options,[1] => bitfields,[2] => attachmentcache,[3] => forumcache,[4] => usergroupcache,[5] => stylecache,[6] => languagecache,[7] => products,[8] => pluginlist,[9] => cron,[10] => profilefield),[itemarray] => Array (),[registry] => vB_Registry Object ( *RECURSION*,[dbobject] => vB_Database Object ([functions] => ....[This error is long for many screens.]

    How to repair it?

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography

    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.