Announcement

Collapse
No announcement yet.

missing avatars on new server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • missing avatars on new server

    I have made an exact replica on my forum on another server. Everything gets transferred just fine except around half of the avatars doesn’t work. Avatars are served from the database.

    Using mysqlfront I can browse the test database online and see the pictures from the blobs are there correctly also for the avatars it cant show (in mysqlfront you can actually see the pictures). The links to image.php are correct. Avatars are under max size etc.

    Admin CP -> Maintenance -> Repair / Optimize Tables didnt help.

    I have run out of ideas. Any ideas why half of the avatars doesn’t show?
    Last edited by KrisP; Sun 16th Nov '08, 9:15am.

  • #2
    Are you sure they are in the database?

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions


    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I was using third party software that didnt upload blobs correctly when they are not stored in hex. (mysqlfront and swordsky). Worked with bumptimer however.

      Comment

      Loading...
      Working...
      X