No announcement yet.

RSS Poster Robot XML error: XML Error: "not well-formed (invalid token) at line 9"

  • Filter
  • Time
  • Show
Clear All
new posts

  • RSS Poster Robot XML error: XML Error: "not well-formed (invalid token) at line 9"

    Hi Everyone,

    My RSS Feeds for our VB forum ( was working fine until Nov 3, after our website server switched from PHP5 back to PHP4...

    The RSS scheduled tasks indicates that it runs fine, but I noticed that there was no more news being posted in the News section.

    I ran the RSS feed scheduler manually, and I received this error for all of my news feeds in the Admin Panel:

    XML Error: not well-formed (invalid token) at line 9
    I appreciate the help and feedback regarding this.


  • #2
    Hi Everyone,

    I just upgraded my vbulletin installation to the latest version (3.7.4), and I am still receiving this RSS Feed error.

    I would appreciate any ideas or feedback to help resolve this.




    • #3
      Its possible the feeds that you're requesting are malformed, or are getting that way when the server finishes downloading them.


      • #4
        Hi Zachery,

        Merry Christmas

        Thanks for your feedback and response.

        What is strange, is because the Yahoo news feed stopped working at the same time that I reverted to PHP 4 from PHP 5, I thought that since nothing changed with the news feed code, that it should be working.

        I did a test with a Google news feed tonight, and the Google feed IS working and posting.

        This is the URL format for one of the Yahoo News feeds that I am using (and that is not working):

        Do you have an idea as to why I receive the XML error on this RSS URL?

        Would someone be able to test this feed URL in their VB forum?

        Thanks for your help and feedback.



        • #5
          Its possible that your libxml or xml libraries in general are out of date or mismatched. Did you have a specific reason to downgrade to php4?


          • #6
            Hi Zachery,

            Yes, I downgraded to php v4 because of a bug in php5 that affected one of my php forms for a "Tell a Friend" script.

            My webhost for this account in ipower (fortunately, and unfortunately )... But I assume that they keep their xml files up-to-date... What question would I post to ipower tech support? Ask them if their XML libraries are up-to-date?

            Two questions come to mind about this error:

            1) what is "line 9" that is referred to in the error message. Is that referring to an error in VB code?

            2) Why does the Google feed work, but not the Yahoo feed?

            Is it possible to do a test of the Yahoo RSS URL on another VB installation?

            Thanks for your ideas about how to resolve this.



            • #7
              I am having the same problem as you. I am getting exactly the same error message with my Yahoo RSS feed, and also with the URL for your news feed. I think it is safe to say that the problem is not with the XML and not with vBulletin.

              I say that for a couple of reasons. I’ve been down this road before. A year ago I posted this message about an XML error with a Yahoo news feed. If others will test your feed (or mine which is referenced in that thread) I think they will find it is working because they are on a different host.

              As I said - I tested your feed and got the same error message. But I got it to work by saving the data referenced in your URL as an xml file. I then FTPed that xml file to my web site and pointed the vBulletin RSS feed to it. The feed worked without error as a local file, but the exact same data produces the XML error when its referenced over the hosting network. What is up with that I don’t know - and apparently nobody else does either. I’ll try to attach the xml data I used in a zip file.

              A year ago I was running vB version 3.6.5 and upgraded in hopes of eliminating the error. As in your case - upgrading did not help with this particular error. When I moved to a new hosting company the XML error went away. But now after a year it’s back again and I have changed nothing. However, my hosting company has moved to a platform called Windows 2003 Server Enterprise, running MySQL Version: 5.0.45, PHP Version 4.4.7. And after this move is when the XML errors started again. I was on Windows 2000 platform before the move.

              So if it isn’t the XML, nor the software, then what else could it be? If the XML is becoming malformed by server then why would other feeds be working? The technical support team with my host has been trying to figure this out for weeks. If you will provide me (via PM) the name and email for your hosting support I will try to get them all working together. If someone can get this working before they do I’ll gladly send you a check for 25 dollars. I really don’t feel like changing hosts again.
              Attached Files


              • #8
                Hi Gcox,

                Thank you for posting your experience with the same issue.

                It is interesting to know that even though we host our websites on different webhosts (I'm with, that we are experiencing the same issue.

                I think that it would be helpful if we knew which file and code the error was referring to:

                XML Error: not well-formed (invalid token) at line 9
                Which file above is being referenced, and what does the code on line 9 say?

                If the XML is becoming malformed by server then why would other feeds be working?
                My question exactly.

                I want to try to isolate the issue more, so I have just installed WordPress (which has RSS fee capabilities)... I'm going to create a Yahoo feed there and see if it is non-vbulletin software can access the Yahoo feed. This should help tell us if it is a vbulletin issue, or an XML issue.

                By the way, here are my server's specs on the server:

                Platform Type

                MySQL Version

                Perl Version

                PHP Version
                Please feel free to contact ipower (They are a BIG company, but it's worth a try contacting them:

                email: support (at)
                support phone: 800-511-4678

                If we can narrow the issue a bit more and receive some more specifics, then I will contact them with details of the issue (I think that at this point, if we approach them with a general issue, they might try to "Microsoft" us and say that it is software related, and that we have to work with the software company).

                When I install and test the Yahoo feed on my WordPress installation, I will post the results here.

                Again, thank you for posting your experience here so that we can try to understand and resolve the issue.



                • #9
                  I tried to use that same Yahoo RSS feed link in WordPress, and...

                  I receive this error in the WordPress RSS widget:

                  Error: could not find an RSS or ATOM feed at that URL
                  So, it seems like it has more to do with the format of the Yahoo feed.

                  Is there anyone out there who is using php 4.x that has a working Yahoo News RSS feed?

                  Thank you again for everyone's feedback.



                  • #10
                    related to PHP 4.4.7

                    Hi Gcox,

                    I see that we are both runnng PHP 4.4.7...

                    Since this issue occurred AFTER I reverted to 4.4.7 from PHP 5.x, I wonder if this issue has something to do with the Yahoo News feed (and perhaps other news feeds) and PHP 4.4.7.

                    Also... I just contacted and placed a support ticket with tech support to see if they can figure out the issue...

                    I may just go back to php 5.x if we can't resolve the issue (I reverted to PHP 4.4.7 because of a bug in PHP 5.x that caused a "Tell a Friend" form display error).



                    • #11
                      Hello again,

                      I went back to php 5.x, and although the Yahoo feed now works in WordPress on my site, my VB Yahoo feed is still not working, and I am receiving a new error in the RSS manager:

                      XML Error: Comment not finished at Line 10
                      Thanks for your thoughts and ideas.



                      • #12
                        I was doing a bit more research online, and found on a PHP developers site that the second error that I am receiving ("XML Error: Comment not finished at Line 10 ") might have to do with updating "libxml2" and "libxslt"

                        The link to that thread is here:

                        I just updated my support ticket to ask ipower if they have the most current versions of "libxml2" and "libxslt" installed.



                        • #13
                          If you want to know what line 9 or line 10 says why can’t you just point your browser at your RSS feed link and look at it?

                          If the problem was with vB software or the xml libraries then wouldn’t the XML errors be consistent? In other words, I get the error “XML Error: not well-formed (invalid token) at Line 9” when I run the vB rssposter against your URL.

                          But if I run the rssposter against the same data residing in a file on any server I do not get the error. I’ll leave the file at this URL for a few days if you want run a rss test against it.

                          If the Yahoo rss data is generated dynamically then I get the error, but put the data in a file and it will process without errors. It’s the same XML data. By the way - I'm using Internet Explorer. If you use some other browser you may not see the XML.
                          Last edited by Gcox; Sat 27 Dec '08, 4:24am.


                          • #14
                            Hi Gcox,

                            I'm not sure which file the error on line 9 or 10 is referring to.

                            Is it the vbulletin file that is processing the RSS feed, is it the XML file, or is it the actual RSS feed page?

                            There is also the fact that thousands of other websites are successfully posting Yahoo RSS news feeds, so there is something that is not working between the combination of the Yahoo feed, the XML server files, and the vbulletin software.

                            Feeds from other news organizations that I have tried ARE working, it is just the Yahoo feed that is not working.

                            And, although the non custom Yahoo news feeds DO work on my WordPress installations, the custom Yahoo RSS news feed (with a custom search term) is not working.

                            It's odd.



                            • #15
                              Its the XMl file.


                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.