No announcement yet.

Adding and Administrator does not work correctly

  • Filter
  • Time
  • Show
Clear All
new posts

  • Adding and Administrator does not work correctly

    Working on a 3.6.7 PL1 vbulletin install, about to start the upgrade process once the owner digs up his customer number (mine wont work to download an upgrade package useable on his site will it?)...

    I ran into this problem.

    Using the forums admin account (userid 1), I changed my normal user on his forum to be in the Administrators group. When logged in as 'admin' I can see all permissions are YES for my normal user now, and indeed on the forum I can read anything and post anywhere now.

    However logging into the AdminCP with my newly admin-ified account, I only show the following menu options to the left:

    vBa CMPS
    Statistics & Logs

    So is this user only a moderator now? It shows Administrator as primary usergroup with no secondaries.

    If it is not actually in the Administrator group, how can I post in an administrator only announcement section?

    Is there anyway to flush the user, and re-add it to the Administrator group to fix this?
    [email protected]

  • #2
    You need to make yourself a Super Admin in order to do this. Edit this section of config.php:

    // ****** SUPER ADMINISTRATORS ******
    // The users specified below will have permission to access the administrator permissions
    // page, which controls the permissions of other administrators
    $config['SpecialUsers']['superadministrators'] = 'x';

    ...and replace x with your userid (not user name.)
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography

    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    • #3
      Just wanted to say that even though this thread is a year old, it was helpful to me! Thanks!


      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.