Announcement

Collapse
No announcement yet.

Safari unable to upload - "Bad Request"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Safari unable to upload - "Bad Request"

    Hello -

    I have a problem at my forum that appears to only affect Safari users. Attempting to upload any file (Attachment, Avatar, or even the diagnostic test upload) or do the same from a URL results in the following:

    Bad Request

    Your browser sent a request that this server could not understand.
    Apache/2.2.0 (Fedora) Server at ***** Port 80
    ...Steps I've taken so far to try to resolve this:

    1. re-uploaded all vBulletin files as text, checking for suspect file versions
    2. disabled all modifications
    3. created a new style, reset Safari cookies and cache, and tried within new style
    4. Various other desperate gambits like repairing tables, postbits, etc.

    Attachment upload appears to work fine in all other browsers.

    In case it's relevant, results from the upload diagnostic (from firefox, of course)

    file_uploads: On
    open_basedir: None
    safe_mode: Off
    upload_tmp_dir: None
    upload_max_filesize: 2.00 MB
    Thanks in Advance for any advice!
    Last edited by septimus; Tue 15 Jul '08, 4:16pm.

  • #2
    Your upload_temp_dir is set to none and this can cause problems with attachments. You will need to contact your host to resolve this.

    Comment


    • #3
      Actually, we resolved it by loosening a certain mod_security setting (the .htaccess method didn't work).

      Thanks for the reply!

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X