Announcement

Collapse
No announcement yet.

Can't resolve "File does not contain expected contents" in Diagnostics

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't resolve "File does not contain expected contents" in Diagnostics

    I've had some issues trying to do an upgrade to 3.7, so in trying to go back to my 3.65 version, I discovered some other issues. (Not sure what version I was at as an IT team recovered the forum from a crash some time back).

    Anyway, since my upgrade to 3.7 didn't work, I tried re-uploading my backup, but had issues getting it running. I ended up cleaning out most or all of the 3.7 files, doing several routines under Diagnostics/Suspect File Versions. I had to really scour and downloaded vBulletin fresh to replace files that reported "File does not contain expected contents" (FDNCEC).

    I'm down to my last 5 files that report FDNCEC, and I have no idea why I can't seem to sync the right versions. I deleted the files from the server, did a fresh download from vBulletin.com of 3.6.5, uploaded the new files in ASCII, and I still get the following...


    upgrade_364.php File does not contain expected contents
    upgrade_365.php
    File does not contain expected contents
    vbulletin-adminhelp.xml
    File does not contain expected contents
    vbulletin-language.xml
    File does not contain expected contents
    vbulletin-settings.xml
    File does not contain expected contents
    vbulletin-style.xml
    File does not contain expected contents

    Whatever is going on with those, I think is the source of the following error:

    The message you have entered is too short. Please lengthen your message to at least 1 characters.


    After doing some research, I was sure to try each of the following without success (I even uninstalled the one plugin I had):

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.
    Last edited by SurfCityvBer; Tue 8 Jul '08, 9:12pm.

  • #2
    I will add that I thought I was at version 3.6.8 (at least through an update, not upgrade) before this all happened, but my admincp screen is saying I'm at 3.6.5.

    I did run the install/upgrade.php routine at some point with success (only out of desperation), but I still get the FDNCEC error.


    Related to this, it might be helpful to have some sort of version code in these files when viewed with a text editor.

    Comment


    • #3
      This means that you either did not run upgrade.php, or you did not upload all the 3.6.8 files when you upgraded.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X