Announcement

Collapse
No announcement yet.

Database error email flood

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database error email flood

    Mysql failed on my server and in the next 10 minutes I got over 300 Vbulletin error emails about not connecting.

    I am sure that there must be a setting to limit the same email from flooding my inbox but I don't know where it is.

    Something like only getting 1 email on the same issue limited to every 10 minutes?

    Please direct me to this setting or offer a solution. Version 3.6.10

  • #2
    Unfortunately there is no option to do that. You can use this instead:

    Admin CP -> vBulletin Options -> Error Handling & Logging -> Log Database Errors to a File and Disable Database Error Email Sending
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Steve,

      Thank you for your reply.

      I do want to know about the problem, but just not 300 times in 10 minutes. Logging to a file will just make the file grow larger and larger until it is too large. I guess I could have a cron job to delete it regularly. But I wouldn't know about the problem.

      Perhaps this could be a feature in a future release?

      Also does anyone know if this is an add on at Vbulletin.org?

      Comment


      • #4
        Not if you set this: Maximum File Size of Error Logs
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Steve,

          Under the "Disable Database Error Email Sending" section at the bottom of the page you referred me to it states:

          Error reports about database connection errors will still be sent.

          That was exactly the errors that flooded my inbox and what I wanted to avoid. Any other ideas?

          Comment


          • #6
            Not if you choose the option I posted previously:

            Admin CP -> vBulletin Options -> Error Handling & Logging -> Log Database Errors to a File and Disable Database Error Email Sending
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol View Post
              Not if you choose the option I posted previously:

              Admin CP -> vBulletin Options -> Error Handling & Logging -> Log Database Errors to a File and Disable Database Error Email Sending
              It don't work. I set it as you suggested as follows:

              Admin CP -> vBulletin Options -> Error Handling & Logging -> Log Database Errors to a File

              I inserted the path to the file as follows:

              /home/forum/public_html/errorlogs/databaseerrors.log

              I created databaseerrors.log file and chmod it to 666 and also the errorlogs directory to 666. I first tried it without creating the databaseerrors.log file but no file was created so I created the file.

              Under:
              Admin CP -> vBulletin Options -> Error Handling & Logging ->Disable Database Error Email Sending

              I checked "yes" and saved my settings.

              Then I restarted Mysql. I got 7 "cannot connect" database error emails!

              As I pointed out before in the Admin CP -> vBulletin Options -> Error Handling & Logging ->Disable Database Error Email Sending section it states "Error reports about database connection errors will still be sent."

              However you told me that was not the case. I am totally confused.

              Comment


              • #8
                As per the instructions that directory and file needs to be chmod'd to 777, not 666.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  The instructions do not say 777, they say to make it "writeable" which 666 is. 777 is readable, writeable and executable.

                  I will 777 it and get back to you.

                  Followup:

                  777 made no difference. Restarted Mysql and got 2 database connection error messages and none were logged to the file.

                  Again I ask:

                  If this will stop the error emails why does it say "Error reports about database connection errors will still be sent" in the Admin CP -> vBulletin Options -> Error Handling & Logging ->Disable Database Error Email Sending section?
                  Last edited by treasureman; Tue 20 May '08, 6:10pm. Reason: followup

                  Comment


                  • #10
                    1. To log to a file, do not put .log on the path to the file in the vB Options.

                    2. To disable the sending of the emails remove the email address from config.php
                    Kerry-Anne :)

                    Twitter Blog

                    www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X