Announcement

Collapse
No announcement yet.

My forum keeps crashing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • My forum keeps crashing

    My forum keeps crashing whenever a certain amount of members/guests are on it.

    I've tried using the '*NIX Server Load Limit' option in the Admin CP and have set it to 5, but I'm still getting a database error whenever the forum has a lot of members/guests on.

    Are there any other solutions that anyone can think of?

    Disallowing guests to read threads isn't an option.

    I'm using a VPS Server at the moment.

  • #2
    You can try turning off any server intensive mods - like chat boxes. It's hard to just *know* what you should do.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      I haven't got any server intensive mods running.

      Comment


      • #4
        Nobody is using his flashchat except myself, as he just left the room.

        To turn off persistent connection (pconnect), located in your includes/config.php file and change what maybe set to 1 back to 0 or request your host to increase max_connection (amount of users you are allowed)

        Code:
        	//	****** MASTER DATABASE PERSISTENT CONNECTIONS ******
        	//	This option allows you to turn persistent connections to MySQL on or off.
        	//	The difference in performance is negligible for all but the largest boards.
        	//	If you are unsure what this should be, leave it off. (0 = off; 1 = on)
        $config['MasterServer']['usepconnect'] = 0;

        Comment


        • #5
          When the database error occurs, right click, view source, and give us the actual error.

          I suspect it's related to you hitting your maximum connection limit which (should) be easy to increase.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X