Announcement

Collapse
No announcement yet.

Multiple Log-in Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Multiple Log-in Problems

    Some of my forum members are having to log in multiple times. We have tried clearing cookies and caches but this problem persists.

    It has gotten worse since we upgraded to 3.6.9 and now affects most members but is intermittent and some members do not have this problem at all.

    Does anybody have an idea how to fix this?

  • #2
    How do you mean? Do they log in but when they go to post told that they don't have permission? Are they coming back after being idle on the site for x minutes?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      The user will be automatically logged out if they are inactive for longer than the timeout:

      Admin CP -> vBulletin Options -> Cookies and HTTP Header Options -> Session Timeout

      To resolve this problem you can either increase the timeout or tell your users to check the Remember Me box when they login. That will automatically log them back in when they timeout.

      Also make sure your cookie path and domain are default:

      Admin CP -> vBulletin Options -> Cookies and HTTP Header Options

      The path should be "/" and the domain should be blank.

      Also, some portals and other addons will modify the login form to post to a full URL which can cause these kinds of problems because the login cookie is specific to one host (e.g. the cookie is written to www.domain.com when you are using domain.com). In that case you need to either disable the offending addon or make sure you are using the same host as the login form.

      Comment


      • #4
        Originally posted by Trevster View Post
        How do you mean? Do they log in but when they go to post told that they don't have permission? Are they coming back after being idle on the site for x minutes?
        It is not a timeout problem. When they log in it gives the redirect page and thanks them for logging in but then they get the log in screen again.
        Originally posted by Jake Bunce View Post
        The user will be automatically logged out if they are inactive for longer than the timeout:

        Admin CP -> vBulletin Options -> Cookies and HTTP Header Options -> Session Timeout

        To resolve this problem you can either increase the timeout or tell your users to check the Remember Me box when they login. That will automatically log them back in when they timeout.

        Also make sure your cookie path and domain are default:

        Admin CP -> vBulletin Options -> Cookies and HTTP Header Options

        The path should be "/" and the domain should be blank.

        Also, some portals and other addons will modify the login form to post to a full URL which can cause these kinds of problems because the login cookie is specific to one host (e.g. the cookie is written to www.domain.com when you are using domain.com). In that case you need to either disable the offending addon or make sure you are using the same host as the login form.
        Yes, we have checked all the cookie and timeout options, having our users clear their cache and cookies seemed to give a temporary fix.

        We do not have any addons but it does appear to be a cookie problem.

        Jake, when you say they need to use the same host, are you referring to the host server? Our home page and forums are on the same server...

        I have also had this problem when logging in to the admincp. It accepts and welcomes me but then requires me to log in again.

        Thank you both for helping me pin down and fix this problem!

        Comment


        • #5
          Follow these steps to reset your cookies back to the default values.

          1) Upload tools.php from your "do_not_upload" folder. This should go into your admincp directory.

          2) Load this in your browser by going to: yourforums/admincp/tools.php

          3) Enter your customer ID.

          4) Click on Reset Cookie Path and Reset Cookie Domain.

          5) Delete tools.php from your server.

          6) See if you can login.
          Kerry-Anne :)

          Twitter Blog

          www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

          Comment


          • #6
            Originally posted by MS007 View Post
            Jake, when you say they need to use the same host, are you referring to the host server? Our home page and forums are on the same server...
            I was referring to the domain portion of the URL. I can check your login form to see if it has been modified if you can post the URL to your forum.

            Comment


            • #7
              Originally posted by Kerry-Anne View Post
              Follow these steps to reset your cookies back to the default values.

              1) Upload tools.php from your "do_not_upload" folder. This should go into your admincp directory.

              2) Load this in your browser by going to: yourforums/admincp/tools.php

              3) Enter your customer ID.

              4) Click on Reset Cookie Path and Reset Cookie Domain.

              5) Delete tools.php from your server.

              6) See if you can login.
              Thank you, I will try that tomorrow when I have access to the files that were not uploaded to the server. They are on my partner's computer and she is sleeping.

              Originally posted by Jake Bunce View Post
              I was referring to the domain portion of the URL. I can check your login form to see if it has been modified if you can post the URL to your forum.
              www.graymattersms.com click the forum link and you should get to the forum index page...it is a private forum so you will see the log in or register page.
              Last edited by MS007; Mon 21 Apr '08, 8:50pm. Reason: up too late and making mistakes

              Comment


              • #8
                Kerry-Anne, we have done those steps and the problem still persists.

                Comment


                • #9
                  Originally posted by MS007 View Post
                  www.graymattersms.com click the forum link and you should get to the forum index page...it is a private forum so you will see the log in or register page.
                  The login form looks fine. I don't know what else the problem could be. We can take a look if you submit a trouble ticket with a URL and admin login to your server:

                  http://members.vbulletin.com/members...ontactform.php

                  Comment


                  • #10
                    Originally posted by Jake Bunce View Post
                    The login form looks fine. I don't know what else the problem could be. We can take a look if you submit a trouble ticket with a URL and admin login to your server:

                    http://members.vbulletin.com/members...ontactform.php
                    Thanks for checking it out, Jake!

                    I have submitted a ticket for the problem...this is actually the second ticket about these issues. The first ticket was done when it was only my account doing this but now most of our users encounter this issue.

                    It does not seem a problem for the ones who select "remember me" but not all members can do that...and we should not have to ask them.

                    Comment


                    • #11
                      so what was the reason now and how was it resolved?

                      I have similar problems...

                      Comment


                      • #12
                        I have the same problem - users type in login details, get the welcome screen, then get bounced back to the login page but if they hit F5 to refresh the screen, they're taken to the forums so it must be a cookie problem. vBulletin support says it's something to do with the fact that I've disabled new user registrations (it has to be done this way as the forums are for a specific membership group only and so new users are set up by me with their membership number as username) but suggested I ask on here to see if anyone knows how to prevent this happening. Any advice welcomed as I hate having to tell people to hit F5 to refresh their cache.

                        Comment


                        • #13
                          Originally posted by snoopy5 View Post
                          so what was the reason now and how was it resolved?

                          I have similar problems...
                          Originally posted by linksdesign View Post
                          I have the same problem - users type in login details, get the welcome screen, then get bounced back to the login page but if they hit F5 to refresh the screen, they're taken to the forums so it must be a cookie problem. vBulletin support says it's something to do with the fact that I've disabled new user registrations (it has to be done this way as the forums are for a specific membership group only and so new users are set up by me with their membership number as username) but suggested I ask on here to see if anyone knows how to prevent this happening. Any advice welcomed as I hate having to tell people to hit F5 to refresh their cache.
                          It has still not been resolved...we have told our users to refresh the page or check remember me, not an acceptable solution but all we can do.

                          vbulletin support worked with us as did netfront/zeon, our server company but none of the changes we made fixed the problem permanently.

                          It is frustrating and stinks of a cache problem, but we have found no fix.

                          It only affects some users and does not seem to be a reproduceable thing, so I have no clue what to tell you.

                          Comment


                          • #14
                            some of my user reportetd, that this problem goes away if the type in the url without the www in front of it. i.e. "vbulletin.com" instead of "www.vbuletin.com"

                            But this is neither a solution for all of teh users who have problems.

                            This is really serious and should get resolved quickly.

                            Since it affects all browers (firefox 2, IE 7 and Safari) I do not think that it can be because of a browser update...

                            Comment


                            • #15
                              We are also having these issues on my forum (just upgraded to 3.7 gold) and have tried all of the above to no avail.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X