Announcement

Collapse
No announcement yet.

File attachments timing out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • File attachments timing out

    hi

    I have the file attachments set to go to the database. In the past I had problems with permissions and such using the file system. But anyways, the database file attachment method seemed to eliminate many of the problems I was having using the file system, but I still am running into some problems for some people, not all.

    What happens is that the file attachment process seems to time out on larger files, i.e. around anything over a half mb or larger for some people. the settings are adequate for larger sizes, and everything seems to be set correctly. Is there anything I may have to change or set on the server side? This problem does not happen to everyone. There is a mod on my forum that has never been able to upload files at all, no matter what size they are, and then there are a few people (me included as admin) that have sporadic problems with the time out issue.

    Any help or advice would be greatly appreciated.

    jj

  • #2
    In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf (or my.ini for Windows systems)

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Note: Do NOT use MB, just M for the megabytes setting.

    You may also need to increase the memory_limit, max_execution_time and max_input_time variables in php.ini.

    Also you might want to take a look at this for other settings that affect file uploads:

    http://www.vbulletin.com/forum/showp...0&postcount=12
    http://www.vbulletin.com/forum/showt...319#post748319
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X