Announcement

Collapse
No announcement yet.

Firefox problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Firefox problem

    My Firefox users experience intermittent errors when accessing various posts/threads/searches with my forum. I have verified the behavior and can't find any pattern. Sometimes it happens, sometimes it doesn't. I verified with Firefox 2.0.0.13. I do not experience the issue with IE and no IE users have reported problems. The problem manifests itself as malformed HTML, but I can see a MySQL problem returned in the response. Here's the page in its entirety(forum mysql user Xed out):

    asforums.com</a> home page, then try to open another page.</li>
    <li>Click the <a href="javascript:history.back(1)">Back</a> button to try another link.</li>
    </ul>
    </td>
    </tr>
    <tr>
    <td class="bodytext" colspan="2">The www.alltexasforums.com forum technical staff have been notified of the error, though you may <a href="mailto:XXX">contact them</a> if the problem persists.</td>
    </tr>
    <tr>
    <td class="bodytext" colspan="2">&nbsp;<br />We apologise for any inconvenience.</td>
    </tr>
    </table>


    <!--
    Database error in vBulletin 3.6.8:

    Invalid SQL:

    CREATE TABLE IF NOT EXISTS vb_taggregate_temp_1206597360 (
    threadid INT UNSIGNED NOT NULL DEFAULT '0',
    views INT UNSIGNED NOT NULL DEFAULT '0',
    KEY threadid (threadid)
    ) ENGINE = MEMORY;

    MySQL Error : CREATE command denied to user 'XXX'@'localhost' for table 'vb_taggregate_temp_1206597360'
    Error Number : 1142
    Date : Thursday, March 27th 2008 @ 07:31:42 AM
    Script : http://www.alltexasforums.com/cron.php?&amp;rand=801638
    Referrer : http://www.alltexasforums.com/index.php
    IP Address : 192.168.1.1
    Username : Unregistered
    Classname : vB_Database_MySQLi
    -->


    </body>
    </html>

  • #2
    You need to assign CREATE permissions for your db user on that database.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      why does it only happen when browsing with Firefox? and why intermittently?

      Comment


      • #4
        It doesn't. It's not browser dependent. To fix this you need to assign CREATE permissions for that db user.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          My bad. Perhaps I was unclear. This error only happens when using Firefox and it is very sporadic. I'll go ahead and try the proposed fix, it just seems odd that it only happens sometimes and with 1 particular browser.

          Comment


          • #6
            Originally posted by Steve Machol View Post
            It doesn't. It's not browser dependent. To fix this you need to assign CREATE permissions for that db user.
            I am sorry to bring something this old back to life but, how do I assign create permissions.....I am new to this

            thanks in advance for the help, I really did try the search!

            Comment


            • #7
              In the future start your own thread please. Contact your webhost for help with assigning permissions to your mysql user.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X