Announcement

Collapse
No announcement yet.

Forum Cache Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forum Cache Issue

    Hey guys,
    I am presuming this is a problem with the caching.
    Myself and users are having problems where we need to be refreshing all the time to see if there is a new thread or something.

    eg 1. i go to the forum home page and there will be no unread forums, then i do a full refresh (shift + refresh in firefox) and then all the unread forums will come up.
    eg 2. there is a unread forum on the homepage, i go in there and there will be no unread thread, so i will need to do a full refresh, and it will show up.
    eg 3. users are having trouble logging in. they will log in and it comes up with confirmation message, then goes back to the homepage and they are still not logged in. but if they do a full refresh it will show them logged in.

    What can I do?

    Cheers

  • #2
    This is sort of related to this thread, but I disabled vbdrupal last year and am still having issues.
    http://www.vbulletin.com/forum/showthread.php?t=251126

    Comment


    • #3
      To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

      Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

      [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

      Next, disable all plugins.

      Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

      define('DISABLE_HOOKS', true);

      Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Thanks, i'll try these things and let you know how I go.

        (also i removed my signature, sorry about that)

        Comment


        • #5
          I'm also having this issue

          Comment


          • #6
            Please follow those instructions then if you need further help start your own
            thread with all the relevant details.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X